OpenWebMail won't make

scuba at scuba at
Mon Jun 27 20:14:11 GMT 2005

Hi Bill,

On Mon, 27 Jun 2005, Bill Schmitt (SW) wrote:

|I've been trying to install openwebmail. I've tried portupgrade and make
|and both seem to have the same issue. I get an error message that perl
|5.6.1 or higher is needed and suggesting that I install 5.8. I've done
|that (several times) but I still get the error message. Has anyone come
|across this and have a solution? I'm running FBSD 4.9.

	What the command bellow shows to you:

	# perl -v

	Following is a script to upgrade perl:

    i) Install the perl5.8 port:

         # portinstall lang/perl5.8

        - or -

         # cd /usr/ports/lang/perl5.8
         # make install

   ii) Set the new version of perl to be the default. (This also turns
       off building perl as part of the base system):

         # use.perl port

  iii) Re-install any 3rd party modules, etc that you've installed so
       the new perl can access them.  There should be a neater way of
       doing this...

         # find /usr/local/lib/perl5/{site_perl/5.005,5.00503} -type f \
 -print0 | \ xargs -0 -n 1 pkg_which | sort -u  /tmp/perl-ports

        # vi  perl-ports

           [ Sanity check the results: take out any non-ports (like
            '?'), ports that are now bundled with perl or that you no
 longer wish to have installed ]

         # portupgrade -f `cat /tmp/perl-ports`

  iv) All of the versions of automake use perl and have the version to use
as the 1st line. You need to:

         portupgrade -f automake

        to get things ready for your new version of perl.

- Marcelo Souza

More information about the freebsd-questions mailing list