Raising temperature threshold

Matthew Flanagan flanagan.matt at gmail.com
Wed Jun 22 12:33:53 GMT 2005

Hi everyone,

I`ve installed a FreeBSD 5.4-STABLE and I was building some ports when 
suddenly my system shut down. Upon rebooting it and checking 
/var/log/messages, I found the following lines:

Jun 21 16:01:30 bell root: WARNING: system temperature too high,
shutting down soon!
Jun 21 16:01:40 bell kernel: acpi_tz0: WARNING - current temperature
(60.0C) exceeds safe limits

Then I realized what had happened. My acpi_thermal sysctl's are:

hw.acpi.thermal.min_runtime: 0
hw.acpi.thermal.polling_rate: 10
hw.acpi.thermal.tz0.temperature: 50.0C
hw.acpi.thermal.tz0.active: 0
hw.acpi.thermal.tz0.thermal_flags: 1
hw.acpi.thermal.tz0._PSV: 50.0C
hw.acpi.thermal.tz0._HOT: -1
hw.acpi.thermal.tz0._CRT: 60.0C
hw.acpi.thermal.tz0._ACx: 50.0C -1 -1 -1 -1 -1 -1 -1 -1 -1

When I try to raise hw.acpi.thermal.tz0._CRT to 85C (which is the threshold in
the BIOS setup) it doesn't work:

bell# sysctl hw.acpi.thermal.tz0._CRT=3580  # 3580 tenths of Kelvin=85C
sysctl: oid 'hw.acpi.thermal.tz0._CRT' is read only

I've tried /etc/sysctl.conf as well, but I get the same error.

Now, my question is: how do I change this value? I've read several manpages
(acpi(4), acpi_thermal(4), acpiconf(8), and many others) and checked the
handbook, to no avail. Can anyone point me to the right direction?

Thanks a lot,

More information about the freebsd-questions mailing list