Battlefield 2 Server won't start

Freek Nossin freeknossin at
Mon Jun 20 12:58:37 GMT 2005


I was happy when I saw that the Battlefield 2 Linux Server was released. Now
I finally had the chance to run this server (a freebsd machine ofcourse ;))
I thought. After a smooth install (the most annoying parts was accepting the
agreements) I tried to run the server. 

I entered the following command in my BF2 directory:


And then I got this "very nice" error message:

/usr/home/dennis/BF2/bf2/bin/ia-32/bf2_f: /usr/lib/ version
`GLIBCPP_3.2.2' not found (required by

The library the program was looking for wasn't in the location it expected,
as it is a linux library. I made a symbolic link to the correct file:

$ls -al /usr/lib/libstdc++.*
-r--r--r--  1 root  wheel  1709842 Jun 15 22:29 /usr/lib/libstdc++.a
lrwxr-xr-x  1 root  wheel       14 Jun 15 22:29 /usr/lib/ ->
-r--r--r--  1 root  wheel   834196 Jun 15 22:29 /usr/lib/
lrwxr-xr-x  1 root  wheel       40 Jun 15 15:02 /usr/lib/ ->
-r--r--r--  1 root  wheel  1705326 Jun 15 22:29 /usr/lib/libstdc++_p.a


$ls -al /usr/compat/linux/usr/lib/*
lrwxrwxrwx  1 root  wheel       18 Mar 21 21:42
/usr/compat/linux/usr/lib/ ->
-rwxr-xr-x  1 root  wheel  4181584 Sep  4  2002

but I still get the same error message. Perhaps it has something to do with
the note about GLIBCPP_3.2.2. I checked my GCC version, which is 3.2.1. Can
this be the cause? Or what can else cause this kind of error? 

I am currently running FreeBSD 5.3

You could make my day I one of you know how to solve this!

Kind Regards,


More information about the freebsd-questions mailing list