Subversion upgrade problems (1.1.3 to 1.2.0)

Ron Gilbert lists at
Fri Jun 17 15:08:41 GMT 2005

I have been running subversion 1.1.3 for about a month with no 
problems.  I just upgraded to 1.2.0 and now I can't connect the the 
server anymore.  I am using svnserve on FreeBSD 5.4.

When I try and connect, I get:

svn: Can't connect to host '': Connection refused

I have tried connecting from my XP machine and from the local machine 
and I get the same error.  I can connect from the local machine using 
file://.  I have tried creating a new repository and a new project to 
make sure it is not a compatibility issue with my 1.1.3 repositories, 
but I get the same error.  I've tried anon-access as well as 
auth-access with the same results.

I have verified that the server is running (via ps).  I can't see any 
place that svnserve is writing error logs.  I am starting svnserve via:

svnserve -d -r /home/svn/repository

I've tried running svnserve using --foreground and nothing is printed 
to the screen.

I sounds like the connection is never even getting to svnserve.  Did 
something change from 1.1.3?  Port?  Nothing has changed on the 
machine.  It was working.  I upgraded (using ports) and now it doesn't 

Any suggestions?


More information about the freebsd-questions mailing list