Error compiling ipfw2 on FreeBSD 4.11-RELEASE and 4.11-p10

Paul Hamilton paulh at
Mon Jun 13 11:58:23 GMT 2005


Thanks.  Hmm, I am pretty sure you still need to re-compile IPFW etc.

After a bit of a panic, and a dig around, I found that things have changed,
and the compiled ipfw file is now located in:
/usr/obj/usr/src/sbin/ipfw/ipfw  this can then be copied to /sbin/ipfw same
for the file.


I don't think it was it was like this in 4.10.  Must be a 4.11 thing.



-----Original Message-----
From: fbsd_user [mailto:fbsd_user at] 
Sent: Monday, 13 June 2005 7:45 PM
To: Paul Hamilton
Subject: RE: Error compiling ipfw2 on FreeBSD 4.11-RELEASE and 4.11-p10

I think ipfw2 has replaced ipfw in the base release by 4.11. You nolonger
have to do anything after compiling the kernel.

-----Original Message-----
From: owner-freebsd-questions at
[mailto:owner-freebsd-questions at]On Behalf Of Paul Hamilton
Sent: Monday, June 13, 2005 7:31 AM
To: Freebsd-Questions
Subject: Error compiling ipfw2 on FreeBSD 4.11-RELEASE and 4.11-p10


I have upgraded from FreeBSD 4.7 to 4.11-RELEASE via booting from CD 1.

I have IPFW2 options already set in my kernel config file, and in

Next, I recompile the kernel, and install it.  Then I went to the
/usr/src/sbin/ipfw dir:-

/usr/src/sbin/ipfw-121 <mailto:phroot at ant[7:19pm]/usr/src/sbin/ipfw-121> #
make clean rm -f ipfw ipfw2.o ipfw.8.gz /usr/src/sbin/ipfw-122
<mailto:phroot at ant[7:19pm]/usr/src/sbin/ipfw-122> # make -DIPFW2
cc -O -pipe  -Wall -DIPFW2    -c /usr/src/sbin/ipfw/ipfw2.c
/usr/src/sbin/ipfw/ipfw2.c: In function `list':
/usr/src/sbin/ipfw/ipfw2.c:1698: warning: `last' might be used uninitialized
in this function
cc -O -pipe  -Wall -DIPFW2     -static -o ipfw ipfw2.o
gzip -cn /usr/src/sbin/ipfw/ipfw.8 > ipfw.8.gz /usr/src/sbin/ipfw-123
<mailto:phroot at ant[7:19pm]/usr/src/sbin/ipfw-123> # l total 226
  2 drwxr-xr-x   2 root  wheel    512 Apr 10 17:32 ./
  2 drwxr-xr-x  82 root  wheel   1536 Apr 10 17:20 ../
  2 -rw-r--r--   1 root  wheel    196 Jul 24  2002 Makefile
 64 -rw-r--r--   1 root  wheel  65358 Jun 16  2004 ipfw.8
 62 -rw-r--r--   1 root  wheel  62391 Apr 10 17:20 ipfw.c
 94 -rw-r--r--   1 root  wheel  95621 Nov  9  2004 ipfw2.c

I have also tried running 'make' by itself (with out the -DIPFW2

So just as a test, I tried doing the same thing from another FreeBSD
4.11-p10 server (IPFW2 was installed during the buildworld-installworld
process).  I got the same error when manually trying to compile IPFW2!  I
have never had a problem before.

What am I doing wrong here?  Any clues?


freebsd-questions at mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list