make installkernel fails instantly w/ signal 11

Keyser keyser456 at
Sat Jun 11 14:03:03 GMT 2005

In an effort to get the simplest of compiled c++ programs (compiled with g++) to actually run without a segfault on my box I'm trying to update everything.  So I cvsup'd src-all and ports-all.  Then I did:

make -j4 buildworld (which worked)
make -DALWAYS_CHECK MAKE buildkernel (which also worked)

However, then when I try to installkernel I get a signal 11 immediately as shown below.  I've tried it in single user mode with the same result.  Not sure what I'm doing wrong?  I've read signal 11 is usually caused by hardware issues but it seems strange this box could build both world and kernel without any problems if that were the case.

vitoc# cd /usr/src
vitoc# pwd
vitoc# ls
COPYRIGHT       UPDATING        gnu             rescue          usr.bin
LOCKS           bin             include         sbin            usr.sbin
MAINTAINERS     contrib         kerberos5       secure
Makefile        crypto          lib             share
Makefile.inc1   etc             libexec         sys
README          games           release         tools
vitoc# make -DALWAYS_CHECK_MAKE installkernel
>>> Making hierarchy
cd /usr/src;  MAKEOBJDIRPREFIX=/usr/obj  MACHINE_ARCH=i386  MACHINE=i386  CPUTYPE=  GROFF_BIN_PATH=/usr/obj/usr/src/tmp/legacy/usr/bin  GROFF_FONT_PATH=/usr/obj/usr/src/tmp/legacy/usr/share/groff_font  GROFF_TMAC_PATH=/usr/obj/usr/src/tmp/legacy/usr/share/tmac PATH=/usr/obj/usr/src/tmp/legacy/usr/sbin:/usr/obj/usr/src/tmp/legacy/usr/bin:/usr/obj/usr/src/tmp/legacy/usr/games:/usr/obj/usr/src/tmp/usr/sbin:/usr/obj/usr/src/tmp/usr/bin:/usr/obj/usr/src/tmp/usr/games:/sbin:/bin:/usr/sbin:/usr/bin /usr/obj/usr/src/make.i386/make -f Makefile.inc1 hierarchy
cd /usr/src/etc;                /usr/obj/usr/src/make.i386/make distrib-dirs
mtree -eU  -f /usr/src/etc/mtree/BSD.root.dist -p /
mtree -eU  -f /usr/src/etc/mtree/BSD.var.dist -p /var
*** Signal 11

Stop in /usr/src/etc.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

I've literally done everything "by the book" but maybe I've missed something obvious to someone else?

More information about the freebsd-questions mailing list