error when trying to install mysql 4.1.12

Christian Astrup Bakke christian at
Sat Jun 11 08:10:42 GMT 2005

Jason Taylor wrote:
> I had this same problem also on 4.11 and then discovered that the 
> options from pkgtools.conf weren't being picked up (I'd mistyped 
> mysql41-* as mysq41-*).  Anyway, using the following options made it 
> investigated and have no direct proof, but my guess is that 
> USE_LINUXTHREADS is the key.

i just tried with 'WITH_LINUXTHREADS=yes' to no avail. here is a sample 
from the install with 'make install WITH_LINUXTHREADS=yes clean':


mkdir .libs
-I/usr/local/include/pthread/linuxthreads -I/usr/local/include -O -pipe 
-I/usr/local/include/pthread/linuxthreads -I/usr/local/include 
-felide-constructors -fno-rtti -fno-exceptions -fno-implicit-templates 
-fno-exceptions -fno-rtti -DMYSQLD_NET_RETRY_COUNT=1000000 -o 
.libs/mysql mysql.o readline.o sql_string.o completion_hash.o 
-lreadline -lncurses ../libmysql/.libs/ -lcrypt -lm -lz 
-Wl,--rpath -Wl,/usr/local/lib/mysql
mysql.o: In function `new_mysql_completion(char const *, int, int)':
mysql.o(.text+0x18b0): undefined reference to `rl_completion_matches'
*** Error code 1

Stop in /usr/ports/databases/mysql41-client/work/mysql-4.1.12/client.
*** Error code 1

Stop in /usr/ports/databases/mysql41-client/work/mysql-4.1.12.
*** Error code 1

Stop in /usr/ports/databases/mysql41-client/work/mysql-4.1.12.
*** Error code 1

Stop in /usr/ports/databases/mysql41-client.
*** Error code 1

Stop in /usr/ports/databases/mysql41-server.


as far as i can see, it coughs as the same error. my pkgtools.conf has 
not been touched by me in any way before or after installing mysql (both 

-- christian at asba dot no

More information about the freebsd-questions mailing list