link in handbook appears to be broken

Ted Mittelstaedt tedm at
Tue Jun 7 06:03:36 GMT 2005

>-----Original Message-----
>From: owner-freebsd-questions at
>[mailto:owner-freebsd-questions at]On Behalf Of Steven
>Sent: Monday, June 06, 2005 6:23 PM
>To: Ted Mittelstaedt
>Cc: freebsd-questions at
>Subject: Re: link in handbook appears to be broken

[some deleted]

>I have two physical systems and I have mobile racks in them.  I
>can pull out
>freeBSD 4.11 and insert freeBSD 5.4.  I have discovered that I
>can write to
>the 4x-12x media when using freeBSD 5.4.  I don't even have to
>use DAO (SAO)
>mode, I can use TAO.
>I have freeBSD 4.11 set up the same as 5.4 as far as I can.  I
>have atapicam,
>and the scsi bus and devices mentioned in the handbook.  cd0 is
>reported when
>I boot, but 4.11 doesn't have devfs, so it's not a usable device. But
>cdrecord is using dev=1,0,0 anyway.  After I write it with
>cdrecord, I try to
>mount it and I get an i/o error reported. When I use cdrecord
>cdrecord reports errors indicating the media format is corrupt.
> Perhaps the
>write operation didn't complete under 4.11 but it does under 5.4?
>Anyway to determine what happened?
>I don't believe that devfs is available under 4.11, but I
>really don't believe
>that's the culprit. Any ideas?

Use FreeBSD 5.4?

Please keep in mind that 4.11 was the last release in the 4.X line.
Yours is not the first screwy atapi bug reported for 4.11 that isn't
in 5.X and it won't be the last.  There are already now I think too many
changes in the atapi code to make backporting a bug fix to be anything
than a tremendous chore.  And some of the bugs people will run into are
only fixed by the structural changes that went into 5.X

Your only recourse I think if you want to burn CD's under 4.X is to find
a different burner.  I would look for something that is PIO mode only,
that probably means finding an older one on EBay for a few bucks.

I myself have had mixed sucess with atapi burners under FreeBSD as a
matter of fact.  And in fact I have also had some issues with readers.
Just 2 weeks ago for example I brought up a new server on 5.4, and
it wouldn't read it's CD reader.  I pulled the reader out, took it home,
exchanged it with a reader in one of my machines that was the same speed,
(and it worked fine in that system) took that machine's reader back to
the server whereupon it worked fine.  You can read about this stupidity

I filed this bug mainly in case it might be useful for the atapi driver
author, and in case it might be useful for a user with a similar problem,
not because I expected it to be fixed.  The motherboard in question isn't
even in production anymore.


More information about the freebsd-questions mailing list