Strange bootloader problem

Jaap Boender jaapb at
Wed Jul 27 09:21:00 GMT 2005

[Sorry about the previous message, I hit the wrong key. X and C are very close

>> Since you changed your BIOS, I'm suspecting something fishy with the
>> BIOS settings for disk geometry, like not LBA or something, but you've
>> probably already checked the BIOS setup...

I hadn't thought about the disk geometry, but I have looked at the BIOS, yes.
Unfortunately, it being a DELL BIOS, there weren't many useful settings I
could change (and 'disk geometry' wasn't even mentioned...)

>> Read the boot(8) manpage paragraph starting with "However," which
>> says how to by-pass "/boot/loader" and maybe try that.
>> Also, loader(8) manpage has a boot_verbose variable that might help.

I've just tried them both, but Grub launches the loader immediately, without
any possibility for bypassing. The FreeBSD boot manager just beeps when I try
to boot FreeBSD (presumably due to the same problem). I've also tried loading
the kernel directly from Grub, but the first time this resulted in a lock-up
just after recognizing the ad0 device - and the second and later times I
didn't get even that far.

Nonetheless, the disk geometry avenue looks promising. I'll see if I can get
anywhere using that. Resetting to defaults apparently isn't enough...


   Jaap Boender
"War is God's way of teaching Americans geography."
   -- Ambrose Bierce

More information about the freebsd-questions mailing list