Strange bootloader problem

Jaap Boender jaapb at
Tue Jul 26 15:58:56 GMT 2005

Hi all,

Well, here's one for the books. I've got a Dell Latitude D610, and yesterday
I upgraded the BIOS to its newest version (A04). This worked nicely, but after
the upgrade, the third stage bootloader won't boot the kernel anymore.

I can get to the boot loader from grub, but then it says 'can't find kernel'
and that's it. If I try a ls it says 'no such file or directory' -
incidentally, the file system itself is okay, if I boot from a fixit CD with
-a and use the hard disk as the root partition, it all works fine.

I've tried installing FreeBSD from scratch on another partition, with the same
result. The only thing that goes wrong is /boot/loader not being able to load
the kernel. Well, that and grub not being able to boot the kernel directly,
but that might very well just be Grub...

So now I'm stumped. Does anyone have any advice? I'm running 5.4-STABLE, just
cvsupped, built and installed an hour ago.


   Jaap Boender

More information about the freebsd-questions mailing list