FreeBSD-current/amd64 the only os that works! ;)

Wojciech Puchar wojtek at
Sun Jul 24 15:29:34 GMT 2005

i've just got new system (MSI Nforce 250Gb-based with athlon64).

tried NetBSD, tried FreeBSD-5.4, even tried Windows XP PRO X64 and none of 
them detects builtin network chip. not a lack of driver problem - chip 
isn't listed on PCI bus at all!!!

this motherboard is listed on FreeBSD webpage as having broken BIOS (not 
the only of course) and that's since April 2005 -current runs on it.

and indeed - everything is detected and everything works.


1) what are these all ACPI errors? can them be just ignored or it is a 
2) why - with interrupt controller capable of 24 ints and lots of them 
unused - network card and one of USB controller gets same interrupt 21?

3) is that high system load normal under net traffic. ftp'ing with 
100Mbit/s speed takes about 10% CPU. with such fast CPU is quite a big 
value. is't it an effect of using same interrupt line that USB?

thank you for all help and congratulations for FreeBSD programmers that 
make it fully working on that hardware!

i initially wanted to use NetBSD on it, but FreeBSD at least works :) and 
appears to work much better under high filesystem load - so i will change 
my preferences. and USB mass storage devices really hot plugs and unplugs 

Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
 	The Regents of the University of California. All rights reserved.
FreeBSD 6.0-CURRENT-SNAP005 #0: Sun Jul 24 16:52:47 CEST 2005
     root at new.dom:/usr/src/sys/amd64/compile/local
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) 64 Processor 2800+ (1808.81-MHz K8-class CPU)
   Origin = "AuthenticAMD"  Id = 0xfc0  Stepping = 0
   AMD Features=0xe0500800<SYSCALL,NX,MMX+,LM,3DNow+,3DNow>
real memory  = 268369920 (255 MB)
avail memory = 250380288 (238 MB)
ioapic0 <Version 1.1> irqs 0-23 on motherboard
acpi0: <Nvidia AWRDACPI> on motherboard
acpi0: Power Button (fixed)
pci_link0: <ACPI PCI Link LNK1> irq 3 on acpi0
pci_link1: <ACPI PCI Link LNK2> irq 10 on acpi0
pci_link2: <ACPI PCI Link LNK3> on acpi0
pci_link3: <ACPI PCI Link LNK4> on acpi0
pci_link4: <ACPI PCI Link LNK5> on acpi0
pci_link5: <ACPI PCI Link LUBA> irq 10 on acpi0
pci_link6: <ACPI PCI Link LUBB> irq 10 on acpi0
pci_link7: <ACPI PCI Link LMAC> irq 5 on acpi0
pci_link8: <ACPI PCI Link LAPU> on acpi0
pci_link9: <ACPI PCI Link LACI> irq 11 on acpi0
pci_link10: <ACPI PCI Link LMCI> on acpi0
pci_link11: <ACPI PCI Link LSMB> irq 5 on acpi0
pci_link12: <ACPI PCI Link LUB2> irq 10 on acpi0
pci_link13: <ACPI PCI Link LFIR> on acpi0
pci_link14: <ACPI PCI Link L3CM> on acpi0
pci_link15: <ACPI PCI Link LIDE> on acpi0
pci_link16: <ACPI PCI Link LSID> on acpi0
pci_link17: <ACPI PCI Link LFID> irq 11 on acpi0
pci_link18: <ACPI PCI Link APC1> irq 16 on acpi0
pci_link19: <ACPI PCI Link APC2> irq 17 on acpi0
pci_link20: <ACPI PCI Link APC3> irq 18 on acpi0
pci_link21: <ACPI PCI Link APC4> irq 19 on acpi0
pci_link22: <ACPI PCI Link APC5> irq 16 on acpi0
pci_link23: <ACPI PCI Link APCF> irq 0 on acpi0
pci_link24: <ACPI PCI Link APCG> irq 0 on acpi0
pci_link25: <ACPI PCI Link APCH> irq 0 on acpi0
pci_link26: <ACPI PCI Link APCI> irq 0 on acpi0
pci_link27: <ACPI PCI Link APCJ> irq 0 on acpi0
pci_link28: <ACPI PCI Link APCK> irq 0 on acpi0
pci_link29: <ACPI PCI Link APCS> irq 0 on acpi0
pci_link30: <ACPI PCI Link APCL> irq 0 on acpi0
pci_link31: <ACPI PCI Link APCM> irq 0 on acpi0
pci_link32: <ACPI PCI Link AP3C> irq 0 on acpi0
pci_link33: <ACPI PCI Link APCZ> irq 0 on acpi0
pci_link34: <ACPI PCI Link APSI> irq 0 on acpi0
pci_link35: <ACPI PCI Link APSJ> irq 0 on acpi0
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff,0xcf0-0xcf3 on acpi0
pci_link29: BIOS IRQ 5 for -2145927624.1.INTA is invalid
pci_link23: BIOS IRQ 10 for -2145927624.2.INTA is invalid
pci_link24: BIOS IRQ 10 for -2145927624.2.INTB is invalid
pci_link30: BIOS IRQ 10 for -2145927624.2.INTC is invalid
pci_link25: BIOS IRQ 5 for -2145927624.5.INTA is invalid
pci_link27: BIOS IRQ 11 for -2145927624.6.INTA is invalid
pci_link35: BIOS IRQ 11 for -2145927624.10.INTA is invalid
pci0: <ACPI PCI bus> on pcib0
pci_link29: Unable to choose an IRQ
pci_link23: Unable to choose an IRQ
pci_link24: Unable to choose an IRQ
pci_link30: Unable to choose an IRQ
pci_link25: Unable to choose an IRQ
pci_link27: Unable to choose an IRQ
pci_link35: Unable to choose an IRQ
agp0: <NVIDIA nForce3-250 AGP Controller> mem 0xe0000000-0xe7ffffff at device 0.0 on pci0
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xeb005000-0xeb005fff irq 21 at device 2.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xeb000000-0xeb000fff irq 22 at device 2.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 4 ports with 4 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xeb001000-0xeb0010ff irq 23 at device 2.2 on pci0
usb2: EHCI version 1.0
usb2: companion controllers, 4 ports each: usb0 usb1
usb2: <EHCI (generic) USB 2.0 controller> on ehci0
usb2: USB revision 2.0
uhub2: nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: 8 ports with 8 removable, self powered
nve0: <NVIDIA nForce MCP7 Networking Adapter> port 0xb800-0xb807 mem 0xeb002000-0xeb002fff irq 21 at device 5.0 on pci0
nve0: Ethernet address 00:11:09:d2:83:6b
miibus0: <MII bus> on nve0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
nve0: Ethernet address: 00:11:09:d2:83:6b
pcm0: <nVidia nForce3 250> port 0xbc00-0xbcff,0xc000-0xc07f mem 0xeb003000-0xeb003fff irq 22 at device 6.0 on pci0
pcm0: <Avance Logic ALC850 AC97 Codec>
atapci0: <nVidia nForce3 Pro UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xf000-0xf00f at device 8.0 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
atapci1: <nVidia nForce3 Pro SATA150 controller> port 0x9f0-0x9f7,0xbf0-0xbf3,0x970-0x977,0xb70-0xb73,0xdc00-0xdc0f,0xe000-0xe07f irq 23 at device 10.0 on pci0
ata2: <ATA channel 0> on atapci1
ata3: <ATA channel 1> on atapci1
pcib1: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> at device 14.0 on pci0
pci_link18: BIOS IRQ 22 for 0.6.INTA is invalid
pci_link19: BIOS IRQ 23 for 0.10.INTA is invalid
pci2: <ACPI PCI bus> on pcib2
pci2: <display, VGA> at device 6.0 (no driver attached)
fxp0: <Intel 82551 Pro/100 Ethernet> port 0xa400-0xa43f mem 0xea020000-0xea020fff,0xea000000-0xea01ffff irq 17 at device 10.0 on pci2
miibus1: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> on miibus1
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp0: Ethernet address: 00:07:e9:0a:04:1a
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
ppc0: <Standard parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7 on acpi0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xc8000-0xcbfff,0xcc000-0xcd7ff,0xce000-0xcf7ff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1808811452 Hz quality 800
Timecounters tick every 1.000 msec
IPv6 packet filtering initialized, default to accept, logging limited to 50 packets/entry
ipfw2 (+ipv6) initialized, divert loadable, rule-based forwarding enabled, default to accept, logging unlimited
ad0: 38165MB <Seagate ST340016A 3.19> at ata0-master UDMA100
acd0: DVDR <LITE-ON DVDRW LDW-851S/GS0K> at ata1-master UDMA33
Trying to mount root from ufs:/dev/ad0s1a
cd0 at ata1 bus 0 target 0 lun 0
cd0: <LITE-ON DVDRW LDW-851S GS0K> Removable CD-ROM SCSI-0 device 
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present

More information about the freebsd-questions mailing list