Mysql40-server installation problem

Jacob S stormspotter at
Sat Jul 23 19:29:25 GMT 2005

On Fri, 22 Jul 2005 15:35:40 -0500
Jacob S <stormspotter at> wrote:

> Hello list,
> I'm having some trouble getting mysql installed on a FreeBSD 5.4
> server. When I cd to /usr/ports/databases/mysql40-server and run "make
> install", I get the following error:
> checking for gcc... cc
> checking for C compiler default output file name... Abort trap (core
> dumped) configure: error: C compiler cannot create executables
> See `config.log' for more details.
> ===>  Script "configure" failed unexpectedly.
> Please report the problem to ale at [maintainer] and attach
> the "/usr/ports/databases/mysql40-server/work/mysql-4.0.25/config.log"
> including the output of the failure of your make command. Also, it
> might be a good idea to provide an overview of all packages installed
> on your system (e.g. an `ls /var/db/pkg`).
> *** Error code 1
> You can see the full config.log at
> and the list of packages
> installed on the server is available at
> .
> I've googled the problem but can't seem to find it. Make buildworld
> and make buildkernel have worked, so I don't know why the make install
> shouldn't for mysql40-server. Does anyone have any hints? 

I finally cracked this one. And as cPanel problems often go, it was
similar to a problem I had to fix during the make buildworld a couple
days ago. 

For some reason cPanel has /dev/md0c mounted as /tmp and then /tmp is
mounted as /var/tmp. /var/tmp was mounted noexec, but /tmp was not. And
evidently /var/tmp had been mounted before /tmp, so even though ls -ld
/var/tmp would show it's permissions and I could cd into it, when I
tried to do an ls on anything inside of it it would tell me that
/var/tmp did not exist. 

Gcc is now able to compile code again and ports are installing fine. I
really need to find a better open source control panel so we can replace
cPanel... :-)


More information about the freebsd-questions mailing list