KPovModeler port problem: why no OpenGL?

Andrew Predoehl apredoehl at
Sat Jul 23 00:56:41 GMT 2005

I found a problem when I recompiled the 
graphics/kdegraphics3 port; the build and install were OK, 
but now when I run KPovModeler, it tells me, "No OpenGL 
support" and does not show wireframes anymore.

I'm running FreeBSD-5.4-RELEASE-p4, and recompiling 
because I'm just doing an ordinary portupgrade on 

There was no problem during the configure step.  Configure 
found GL, GLU, GLX, but found them....

checking GL/gl.h usability... yes
checking GL/gl.h presence... yes
checking for GL/gl.h... yes
checking GL/glu.h usability... yes
checking GL/glu.h presence... yes
checking for GL/glu.h... yes
checking GL/glx.h usability... yes
checking GL/glx.h presence... yes
checking for GL/glx.h... yes
checking for GL... yes

The only thing configure said I was missing was libsane, 
which I don't even need because I don't have a scanner.

I'd really like to be able to use KPovModeler properly. 
 Does anyone know how to fix this?  Should I just give up 
and use a package?  Do I need to install Mesa?  It is not 
listed as a dependency, and in fact when I tried to make 
the graphics/mesagl port it says this:

landru# cd /usr/ports/graphics/mesagl/
landru# make configure
===>  Mesa-5.0.1_3 is unnecessary because libGL and libGLU 
come with XFree86 4.0 and higher.

I have libglut-6.0.1 and xorg 6.8.2 already installed, 
along with the all the rest of KDE 3.4.1.


Andrew Predoehl

More information about the freebsd-questions mailing list