Printer won't work

service at service at
Fri Jul 22 06:06:19 GMT 2005

uname -a

FreeBSD localhost 5.4-RELEASE FreeBSD 5.4-RELEASE #0: Wed Jul 20 22:10:32 UTC 2005 

root@:/usr/src/sys/i386/compile/VIL i386


Can't get printer to work. 

I have a P4 compter with SCSI drives and 1 gig of memmory. It runs Mozilla, apache2, 

mysql and php5 perfect. When I try to print something, it doesn't work.

I have a Hewlett-Packard Deskjet-500 printer. I followed the instructions in the Handbook. 

I tested it with the 'lptest > /dev/lpt0' function. It printed one line, stalled for a few 

seconds like it didn't know what to do, then it ejected the sheet and then ran two more 

sheets without trying to print anything. The manual says if it prints something, it okay, 

you can fix the errors later.

I did install the 'ifhp filter' from the /usr/share/examples to /usr/local/libexec/ifhp. 

The 'ifhp filter' is designed for the Deskjet-500 and will also work on most Hewlett-Packards.

My printcap file is:

lp|hp|local line printer:\




My print spool is:


I chowned lpd for deamon,deamon and I also chmoded 770 like the book says.

I used 'lpr file' to try and print something and all I received was:


no daemon to abort

printing enabled

lpc: Unable to connect to /var/run/printer: Socket operation on non-socket

lpc: Check to see if the master 'lpd' process is running.

couldn't restart daemon

This tells you theres no socket and the daemon isn't running. I also checked to see 

if /var/run/printer existed. I cd'd to /var/run and that was it. I ran ls and printer 

did not come up.

I also ran # lptcontrol -i -d /dev/lpt0 for interrupt-driven mode and 

# lptcontrol -p -d /dev/lpt0 for polled-mode. It failed both times.

I know how to use ps -aux the see if apache and mysql are running, but I don't how

to find out if the 'printing daemon" is running. 

I think we need to somehow find a way to get the 'printing daemon' to run.

This is about a far as I can go, hopefully, someone can tell me the steps to get the daemon

going and how to tell if its going.

I also tried this on the same computer with FreeBSD 5.4 without any applications installed. I also 

tried it on Dell-P3 with IDE drives. Both of these produced the same results.

Thanks in advance,


More information about the freebsd-questions mailing list