Weirdness with sfte, screen, and FreeBSD.

Dan MacMillan flowers at
Tue Jul 19 02:45:22 GMT 2005


When I run sfte (20050108) inside of GNU screen (4.00.02) in FreeBSD
(5.4-RELEASE-p2), I get some strange and irritating behaviour.  If I hit
"alt-f" to get the File menu, then press the right arrow key to move to the
next menu over ("Navigate" in the directory view), then that portion of the
screen that WAS covered by the file menu but IS NOT covered by the Navigate
menu has its colors screwed up.  What WAS high-intensity-white on dark blue
becomes black (or dark gray, hard to tell) on green.  What WAS
high-intensity-white on black becomes black (or dark gray) on dark blue.
What WAS light gray on black becomes dark gray on black.  And so on.  If I
then press the right-arrow-key again to move to the "Tools" menu, the
problem becomes progressively worse.  Dark gray becomes blue, blue becomes
light green, light green becomes cyan, etc. etc.  Eventually what was
covered by any of the menus becomes a real colourful mess.  In case this
description is not clear, I've uploaded a clip of a screen grab that
demonstrates the problem after pressing right-arrow a bunch of times with an
open menu:

I have tried to understand terminals and consoles and termcap and terminfo
but I have to say, the concepts escape me.  The only other slang program I
generally use is Mutt, which works like gangbusters.  I don't even know
where to begin looking at this.  Here are some environment variables that
(may) be of interest:

TERMCAP='SC|screen|VT 100/ANSI X3.64 virtual terminal:\

I don't know what other information to include.  I get the problem both
using Putty to SSH in and at the console.  Outside of GNU screen sfte works
like a charm.  Note that in order to get sfte to build on FreeBSD, I had to
link it to both libslang and libncurses (and perform other minor surgery on
the port, viz. comment out USE_XLIBS and change fte-unix.mak to build sfte
instead of xfte since I neither have nor want X installed).

Pardon the cross-post but I really don't know which piece of software might
be at fault.  Any information or pointers would be greatly appreciated.

Danny MacMillan

More information about the freebsd-questions mailing list