Bob Hall rjhjr at
Thu Jul 7 18:39:47 GMT 2005

On Thu, Jul 07, 2005 at 06:55:58PM +0200, legalois wrote:
> Bob Hall wrote:
> >I don't know squat about perl. I recently ran portupgrade, which
> >upgraded perl. Goose stopped working, because the location for
> >was no longer in @INC. I tried to run perl-after-upgrade, but I couldn't
> >get it to run. I've got a book that said to use
> >	# perl perl-after-upgrade
> >or
> >	# ./perl-after-upgrade
> >I also tried just
> >	# perl-after-upgrade
> >No joy. Just for the heck of it, I tried 
> >	* sh perl-after-upgrade
> >and dang if it didn't run. It didn't look to me like an sh script, but
> >what do I know? It wasn't supposed to change anything without the -f
> >option, but goose ran afterward, so it obviously changed things. I
> >looked for, and it moved to a directory listed in @INC.
> >
> >Anybody have any advice? Comments? How was I supposed to get
> >perl-after-upgrade to run?
> >_______________________________________________
> >freebsd-questions at mailing list
> >
> >To unsubscribe, send any mail to 
> >"freebsd-questions-unsubscribe at"
> >
> >
> A longish message appears at the end of the perl upgrade build, that 
> explains how to run perl-after-upgrade. 

As I stated above, I used portupgrade. That means that any messages at
the end of the perl upgrade scrolled off the screen and out of the
screen buffer when portupgrade carried out the next install. One of the
problems with portupgrade is that you rarely see the post-upgrade
messages when you do batch upgrades.

> If you overlooked that, the same 
> instructions are at
> #perldoc perl-after-upgrade

That's identical to the man page, which didn't supply any information
that helped. So if the man page, perldoc page, and post-install message
were the same, none of them contained the information I needed.

> If the script is in a directory not in your root's path, find the full 
> path to the script with
> #locate perl-after-upgrade
> (but make sure your locate db is up-to-date, first).

As I stated above, I tried "./perl-after-upgrade" and I looked at the
script, neither of which would have been possible if I didn't know where
the script was.

As I mentioned in my followup post, I solved the problem with "rehash".
A mention of this in /usr/ports/UPDATING would help those of use who
rarely use tcsh unless we need to run something as root. Also in the man
page. Any situation that requires perl-after-upgrade probably also
requires rehash.

I found the solution at

More information about the freebsd-questions mailing list