Matlab7 (R14)

Dan Olson danolson at
Fri Jul 1 19:42:03 GMT 2005

Rodolphe Conan wrote:
> I have followed the FreeBSD handbook procedure to install Matlab 7.0.
> There are apparently big changes between 6.5 and 7.
> I have used Matlab of FreeBSD since version 5 and it is the first time I
> can't run a new matlab version on FreeBSD.
> Rod 
> On Fri, 2005-07-01 at 09:32 +0200, Norbert Koch wrote:
>>There is a chapter about installing
>>and running Linux software in the
>>FreeBSD handbook. In 10.5 they describe
>>installation of Matlab 6.5. May be
>>that helps.
>>>-----Original Message-----
>>>From: Rodolphe Conan [mailto:rconan at]
>>>Sent: Wednesday, June 29, 2005 6:48 PM
>>>To: Norbert Koch
>>>Cc: freebsd-questions at
>>>Subject: RE: Matlab7 (R14)
>>>I have installed it using the matlab install
>>>script : /usr/compat/linux/bin/sh install!
>>>On Wed, 2005-06-29 at 18:24 +0200, Norbert Koch wrote:
>>>>>I am running FreeBSD 5.3 with linux_base-8 installed.
>>>>>I have installed the linux version of Matlab 7 (R14) and now
>>>when I start
>>>>>matlab 7 I have this warning message:
>>>>>/compat/linux/usr/local/Matlab/bin/matlab: line 1: /lib/
>>>>>cannot execute binary file
>>>>>Any idea what does it mean?
>>>>>Matlab start anyway but I cannot make 3D
>>>>>surface plots (A simple mesh(zeros(20)) will run forever taking all my
>>>>>cpu!!) or even a simple help linspace will freeze matlab?
>>>>How did you install it?
>>>>May be, Matlab tries to run some executable, which is
>>>>not marked as Linux executable. See brandelf(1).
>>>>You could try to run Matlab under ktrace(1) and check
>>>>for exec system calls.
>>>>freebsd-questions at mailing list
>>>>To unsubscribe, send any mail to
>>>"freebsd-questions-unsubscribe at"
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

I am having similar types of problems with Matlab (R14) 
Service Pack 1 on 6.0-CURRENT FreeBSD 6.0-CURRENT #0: Wed Jun 15 
12:38:40 CDT 2005.

Except when I startup Matlab I get, 
"/compat/linux/usr/local/matlab/bin/matlab: line 1: /lib/ 
Interrupted system call" at the command prompt.

Also typing 'opengl info' results in this output:
 >> opengl info
Attempting to load
Warning: Unable to load the OpenGL renderer due to the following error cannot open shared object file: No such file or directory
Tried loading glren shared object from:
 > In opengl at 98
Switching to Software OpenGL Rendering.
Attempting to load
Severe Error querying Opengl.
Click here for more help.

I don't have hardware opengl rendering.

I tried following The Math Works solution number 1-17YM3 which is:
"How do I direct MATLAB to use the Mesa OpenGL libraries or the system 
OpenGL libraries on a UNIX machine?", but it didn't work for me. It 
might be a starting point for you.



Dan Olson

More information about the freebsd-questions mailing list