Xorg config failure - help requested

Alan E. Beard aeb1 at aebeard.com
Sat Jan 29 09:08:49 PST 2005

On Sat, 29 Jan 2005, John wrote:

> On Sat, Jan 29, 2005 at 10:47:08AM -0500, Alan E. Beard wrote:
> > Folks:
> > 
> > Your kind help is solicited in the matter of an xorg config which fails
> > to initialize on
> >    "(EE) Screen(s) found, but none have a usable configuration."
> > 
> > Hardware is Sony PCV-L640, which is packaged from the manufacturer with
> > an LCD display, Sony part number PCVA-15XTAP2.  The maker's spec on the
> > display calls out native resolution of 1024x768, and vidcontrol seems to
> > confirm this.  Additionally, DDC seems to find the display and read a
> > reasonable set of parms. This notwithstanding, xorg server
> > initialization fails.
> > 
> > I've tried explicitly specifying DisplaySize, HorizSync, VertRefresh in 
> > the Monitor block of the conf file, to no avail.
> > 
> > Log files, config files, and supporting data below.
> > 
> > Any ideas concerning some means of torturing this config into working
> > will be welcome.
> I had the same sorts of problems trying to use the x config scripts.
> My advice is to ignore the config scripts and follow the simple
> procedure in the FreeBSD handbook - "X -configure" and then test,
> check the log file to see if the monitor information is in there,
> or if not, search the web for an X11 entry for your monitor, or
> dig up the monitor specs and build it by hand.  Other than the
> monitor part, it is quick and easy.
The procedure you describe above was executed in this case; the conf file 
in the original message was generated by 'Xorg -configure', and the log 
file was generated by 'Xorg -conf /root/xorg.conf.new'.  Additionally, the 
same release of xorg is running successfully on three of my 12 machines - 
the others run x clients only (in the case of the headless boxes), or (in 
two cases) are still running 4.10 with XFree86. This problem appears to be 
specific to the particular hardware configuration described in my initial 
note. (By way of explanation, the machine in question had run W2K until 
last week, but I decided to upgrade it to FreeBSD 5.3 for better 
reliability and improved function.) I have searched the X.org archives 
(and even resorted to google) for config information specific to the 
display called out above - with null result.

> Now I have X.org up and runnning on four different machines - and
> I'm loving it!
See above. Perhaps a detailed look at the log file will reveal to you a 
clue which I have overlooked.  I've not yet tried an explcit 'modeline' 
config - but my interpretation of the log from a subsequent run with the 
explicit monitor parms generated by -configure (but commented out in the 
auto-generated config) uncommented seems to indicate that the 
initialization process is failing to read the "Monitor" block, or the 
values are being overridden.

Any substantive notions will be welcome.



Alan E. Beard <aeb1 at aebeard.com>
AEBeard Consulting; 4109 Chelsea Ln; Lakeland FL 33809

More information about the freebsd-questions mailing list