Graphviz fonts

Kirk Strauser kirk at
Fri Jan 28 17:24:08 PST 2005

I'm trying to use Graphviz's "dot" command to produce a graph.  My input
files are extremely simple:

    digraph familytree {
        WillardKirkStrauser -> { WillardJacobStrauser GabrielleMargaretStrauser ArianaNicoleStrauser };

When I run dot, I get this error:

    dot -Tgif < foo > foo.gif
    Error: Could not find/open font : Times-Roman in /usr/X11R6/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/truetype:/usr/X11R6/lib/X11/fonts/TTF:/usr/share/fonts/TrueType:/usr/share/fonts/truetype:/usr/openwin/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/Type1:/usr/common/share/fonts/ttf

I still get a result, but the text is very large and the resulting graphs
look bad (see for an

I've tried adding every Truetype font path on my system to its "fontpath"
variable, but I get the same error but with a much longer list of 
directories.  Any ideas?
Kirk Strauser
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list