disklabel missing on a raid-5

Peter Wong faxmachine373 at hotmail.com
Fri Jan 28 07:46:01 PST 2005


I'm having a serious problem with one of my freebsd 4.6-R box. I have always 
used Freebsd to run my database servers and I've never had such a problem. 
If anyone knows the solution to my problem below, please let me know because 
I have some really important data that I badly need.

Short story: Someone booted a database server by accident, it won't boot up 
and got hang up right after post (where the /|\ spinning supposedly begins) 
so that person booted it again, and again. (three times in total I think).

Anyway, since it won't boot up at all, I've decided to install a IDE HD with 
Freebsd 4.6 on it, boot up the server and attempt to retrieve the database 
backups from the messed-up raid-5 HDDS that I stored in a /usr/home/backup 

dmesg says:

da0 at asr0 bus 0 target 0 lun 0
da0: <ADAPTEC RAID-5 380E> Fixed Direct Access SCSI-2 device
da0: Tagged Queueing Enabled
da0: 70006MB (143372288 512 byte sectors: 255H 63S/T 8924C)

Looks good. So I go

#mount /dev/da0s1 /mnt

It returns:

Jan 28 23:22:31 /kernel: da0: cannot find label (no disk label)
Jan 28 23:22:31 /kernel: da0s1: cannot find label (no disk label)

And I am able to cd to mnt and read everything, but /usr and /var (that's 
where the data reside) are empty.

Then I tried:

#fdisk da0

and it returns

******* Working on device /dev/da0 *******
parameters extracted from in-core disklabel are:
cylinders=8924 heads=255 sectors/track=63 (16065 blks/cyl)

Figures below won't work with BIOS for partitions not in cyl 1
parameters to be used for BIOS calculations are:
cylinders=8924 heads=255 sectors/track=63 (16065 blks/cyl)

Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 165,(FreeBSD/NetBSD/386BSD)
    start 63, size 143363997 (70001 Meg), flag 80 (active)
        beg: cyl 0/ head 1/ sector 1;
        end: cyl 1023/ head 254/ sector 63
The data for partition 2 is:
The data for partition 3 is:
The data for partition 4 is:

So I tried:

# disklabel da0s1
disklabel: ioctl DIOCGDINFO: Invalid argument
# disklabel da0
disklabel: ioctl DIOCGDINFO: Invalid argument

Is my disklabel missing, and that's why the raid-5 HDDs won't boot up and 
won't let me mount '/usr' and '/var'? Since the etc directory is accessible 
I can even access the old '/etc/fstab' and '/etc/disktab', would that help? 
All I need is to be able to mount /usr and /var and copy the data out to my 
IDE HD, whether the Raid-5 sys can ever boot up again is secondary.

Here's '/etc/fstab' (well '/mnt/etc/fstab'):

/dev/da0s1b             none            swap    sw              0       0
/dev/da0s1a             /               ufs     rw              1       1
/dev/da0s1f             /usr            ufs     rw              2       2
/dev/da0s1e             /var            ufs     rw              2       2
/dev/da0s1g             /www            ufs     rw              2       2
/dev/acd0c              /cdrom          cd9660  ro,noauto       0       0
proc                    /proc           procfs  rw              0       0

Also, as a freaked out person desperatly trying to restore the data I tried 
to mount the slices. I tried:

#mount /dev/da0s1f /mnt

and it returns

mount: /dev/da0s1f on /mnt: incorrect super block

If anybody has any idea on how that can be done, please let me know; If any 
extra info is needed, please let me know and I'll provide them as much as 

Thanks in advance.

Get 10Mb extra storage for MSN Hotmail. Subscribe Now! 

More information about the freebsd-questions mailing list