mystery /var space usage

Nelis Lamprecht nlamprecht at
Fri Jan 28 03:19:58 PST 2005

On Thu, 27 Jan 2005 07:29:30 -0800, joseph kacmarcik
<freebsd-questions at> wrote:
> > /dev/amrd0s1e   9.8G   4.8G   4.2G    53%    /var
> >
> > A du -h of /var shows a total of 616M data only. First thing that came
> > to mind is some process which is holding onto data so I tried
> > restarting various daemons - cyrus, imapd, exim, apache and still no
> > change. I've checked with fstat and lsof to see if I can see anything
> > suspicious but nothing out of the ordinary shows up.
> sounds like the maillog. have you tried restarting syslogd or whatever process
> you have that writes to your maillog?

syslogd was the first process I restarted amongst all the others to
see if the problem could be solved. after doing some googling i came
across this same problem mentioned before.
and another maybe not freebsd related

I have exactly the same problem which leads me to think that this may
be some sort of bug with softupdares ?

mail:/var# du -hs /var
621M    /var

mail:/var# df -h /var
Filesystem      Size   Used  Avail Capacity  Mounted on
/dev/amrd0s1e   9.8G   5.4G   3.7G    59%    /var

the usage for /var is growing all the time so I'm going to have to
take the machine down this weekend which I'm sure will solve the
problem for now but I'd sure like to know what causes this.


More information about the freebsd-questions mailing list