modify existing partitions - newbie

saravanan ganapathy sarav_gsa at
Thu Jan 27 02:42:20 PST 2005


I just needed to delete some partitions(ad0s1e &
ad0s1f) in my existing slice(ad0s1) and recreate with
some changes. 

1) I tried using 'sysinstll --> Config --> Label' ,
then delete e & f , but this couldn't write. It says
'unable to write data on ad0' . What is the problem?

2) Tried using 'disklabel -e ad0s1', then a file
opens. I deleted the last two lines(e & f) and saved. 
Now it shows as the following 

# /dev/ad0s1:
8 partitions:
#        size   offset    fstype   [fsize bsize
  a: 41943040        0    4.2BSD     2048 16384 28552
  b:  4194304 83886080      swap
  c: 320159322        0    unused        0     0      
  # "raw" part, don't edit
  d: 41943040 41943040    4.2BSD     2048 16384 28552

Is it the correct way to delete the partitions?

3) How to add new partitions in the same slice?

( I read lot of links, all are about formatting a new

Please help me


Do you Yahoo!? 
All your favorites on one personal page – Try My Yahoo! 

More information about the freebsd-questions mailing list