Out of the frying pan...

John john at starfire.mn.org
Fri Jan 14 12:12:07 PST 2005

On Fri, Jan 14, 2005 at 01:32:03PM -0600, Andrew L. Gould wrote:
> On Friday 14 January 2005 12:23 pm, John wrote:
> > On Fri, Jan 14, 2005 at 06:19:20PM +0100, Benjamin Walkenhorst wrote:
> > > Hello,
> > >
> > > Andrew L. Gould wrote:
> > > >3. Definitely go with a clean installation of FreeBSD 5.3 rather
> > > > than 5.2.1.
> > >
> > > Just a sidenote, I did a source upgrade from 5.2.1 to 5.3, which
> > > basically worked okay.
> > > Switching from XFree to X.org was really troublesome, on the other
> > > hand...
> >
> > Yes, I would say that the source upgrade from 5.2.1 to 5.3-STABLE was
> > fine, it was the xorg/XFree86 and kde issues that made me insane.
> > It's possible that I should have just done a pkg_delete -a and
> > started over with the packages from that point, but I also need to
> > learn to use pkg_upgrade.  I would not hesitate to do the source
> > upgrade again for a system which is NOT running X.
> >
> > I have now reinstalled 5.3, just to get around the Xorg->XFree86
> > issue, and I have kde installed, and I have room to spare.  So,
> > I'm much farther than I was when I ran out of room, and I still
> > have room.  This is a good thing!
> Yes it is!  (...and speaking as someone who is typing with 2 fractured 
> wrists, all good news is welcome!)

Oh, no!  I'd ask what happened, but I'll wait until you're healed up...

> I hope you have lots of fun and joy with your system before the next 
> challenge (which we will gladly participate in) !

OK, well, it seems I spoke just a little bit too soon.  Or, maybe I'm
OK, but just worried.

I downloaded and burned an ISO 5.3 CD.  I did a minimal install,
NFS mounted all the 5-stable packages I kept from the last time
around (I'm not a COMPLETE idiot!) and simply did a "pkg_add
kde-lite*".  That got me a long, long ways.  I also needed to do
a "pkg_add xorg-server*" but I think nearly everything else got
loaded up.  I was in great shape in terms of disk footprint and
everything else I can tell from here.

Now, at this point, I'm running FreeBSD 5.3-RELEASE, but I've
installed packages from FreeBSD 5-STABLE, but if my understanding
is correct, that should be OK.

This is the point at which things got interesting.  I did the
pkg_add for OOo - and found that I was missing four dependent
packages.  As luck would have it, all four of them have been
updated since I started this process, so I downloaded and installed
the newer revv'ed ones, but I got an error message that
something (I wished I'd trapped the output) wanted libm.so.2.
When I look around, I find that I have libm.so.3.  The four
packages were atk, pango, shared-mime-info, and gtk-2.  I
think one of the post-install scripts complained that it couldn't
run something, 

Am I preparing trouble, or am I OK?  Despite the warning, everything
seems to be installing.  Obviously, I wasn't able to install the
newer packages as dependencies, but after installing them by hand,
the things on which they depended seem to be installing OK, though
with warnings.

Anyway, I have everything installed, (except maybe a JDK - any
suggestions?) and I'm at 80% in my combined root /usr partition,
which feels a little tighter than I would like, but I do still have
270Mb free, so that's not too bad - that's larger than my first
FreeBSD hard drive! :)

OO just finished.  Other than 16 packages that are newer than expected,
it seems to have installed.  I'm not actually with the machine, so I
can't start X and kde and try it.

Am I OK, or should I start over and redo something?

John Lind
john at starfire.MN.ORG

More information about the freebsd-questions mailing list