flock failure on NFS from 5.3 client to 4.7 server

Bruce Campbell bruce at engmail.uwaterloo.ca
Thu Jan 13 19:26:26 PST 2005

Quoting Kris Kennaway <kris at obsecurity.org>:
> > ...
> > After the mail server upgrade to 5.3, flock gives error "operation not supported" 
> > on nfs mounted home directories.
> > ...
> > On our NFS server, rpc.statd is running, but rpc.lockd wasn't.  Started
> > it, still no worky.  Killed it, other 4.7 clients still flock fine.
> rpc.lockd needs to be running on *both* client *and* server.
> 4.x gets away with it because the rpc.lockd implementation does not in
> fact implement locking on the client.
> Kris

Thanks, that has fixed it, and I've added the appropriate rc.conf
settings on the client:

rpc_lockd_enable="YES"           # Run NFS rpc.lockd needed for client/serv
rpc_statd_enable="YES"           # Run NFS rpc.statd needed for client/serv
rpcbind_enable="YES"             # Run the portmapper service
and on the server:

rpc_lockd_enable="YES"          # Run NFS rpc.lockd (*broken!*) if nfs_server.
rpc_statd_enable="YES"          # Run NFS rpc.statd if nfs_server (or NO).

Bruce Campbell
Engineering Computing
University of Waterloo
(519)888-4567 ext 5889

This mail sent through www.mywaterloo.ca

More information about the freebsd-questions mailing list