burncd: "device busy" error when writing .iso

Jason Morgan jwm-freebsd at sentinelchicken.net
Thu Jan 13 10:26:57 PST 2005

On Wed, Jan 12, 2005 at 01:42:43PM -0500, Jason Morgan wrote:
> I am attempting to burn an .iso of the 5.3 mini distribution and keep 
> running into the following error:
> # burncd -f /dev/acd0 data 5.3-RELEASE-i386-miniinst.iso fixate
> next writeable LBA 0
> writing from file 5.3-RELEASE-i386-miniinst.iso size 274400 KB
> written this track 640 KB (0%) total 640 KB
> only wrote -1 of 32768 bytes: Device busy
> fixating CD, please wait..
> I have verified that the drive is working and is accessible.  I have 
> tried different media and keep running into the same result.
> # dmesg | grep acd0
> acd0: DVDR <PIONEER DVD-RW DVR-108> at ata1-master PIO4
> This is a new drive, that I just recently installed.
> Oh, I'm running FreeBSD 5.2.1-RELEASE-p11 #7.
> Any suggestions?  I've only burned CDs with FreeBSD a few times and 
> never on this system, so I'm kinda a newb.
> Thanks for your time.

I finally solved the problem.  I had to include "device atapicam" in my kernel, then used cdrecord instead of burncd, 
using the drive as a scsi device.  Hope this info will help some newb in the future.


More information about the freebsd-questions mailing list