Sound not working - none of the other posts helped

Karol Kwiatkowski freebsd at
Thu Jan 13 08:55:18 PST 2005

> I'm using the latest 5.3-stable build along with the Xfce4 window
> manager. I have a Sound Blaster Audigy card.
> I don't have the line 'device sound' in my kernel, but I have the
> following two lines in my loader.conf file:
> sound_load="YES"
> snd_emu10k1_load="YES"
> Sound doesn't work in X (tried playing an MP3 using a graphical MP3
> player). It doesn't work in command line either (tried using a console
> MP3 player as well). Any idea how to fix this?

I don't use emu10k1 driver (emu10kx[1] instead), but since no one has
replied yet (probably due to missing details):

First I would check if modules are loaded and if card is recognized.

Try following commands (you should see similar output with emu10k1):

> blackacidevil: # kldstat
> Id Refs Address    Size     Name
>  [...snip...]
>  3    1 0xc0827000 11c90    snd_emu10kx.ko
>  [...snip...]

Here I've got only 'snd_emu10kx' listed because 'sound' is compiled in
the kernel. There should be module sound loaded on your system.

> blackacidevil: # dmesg | grep pcm
> pcm0: <EMU10Kx PCM Interface> on emu10kx0
> pcm0: <TriTech TR28602 AC97 Codec>

> blackacidevil: # cat /dev/sndstat
> FreeBSD Audio Driver (newpcm)
> Installed devices:
> pcm0: <EMU10Kx PCM Interface> on emu10kx0 (16p/1r/0v channels duplex default)

If all is OK try adjusting volume with /usr/sbin/mixer.

If not try 'pciconf -lv' and search for sound card information.
Also check emu10kx website (below) - scroll down to 'Basic
troubleshooting tips'.

Hope that helps a bit.


[1] emu10kx can be found:
works great with 5.3-RELEASE-p4 and Audigy (class=0x040100
card=0x00511102 chip=0x00041102 rev=0x03 hdr=0x00)

Karol Kwiatkowski  <freebsd at orchid dot homeunix dot org>

More information about the freebsd-questions mailing list