ntpd problems since upgrading to 5.3

Ian Moore imoore at picknowl.com.au
Tue Jan 11 02:30:47 PST 2005

Ever since I upgraded from 5.2.1-RELEASE to 5.3-RELEASE, I've been getting the 
following error on boot:
ntpd[380]: bind() fd 7, family 28, port 123, addr fe80:1
::204:61ff:fe46:be89, in6_is_addr_multicast=0 flags=0 fails: Can't assign 
requested address

ntpd seems to be working from what I can see in it's log file, but I can't do 
anything with ntpq to check it. 
Wether I run it as my normal user or as root, running ntpq -p always gives:
ntpq: write to localhost.foo.com failed: Permission denied

I can run ntpq without any flags (and get the ntpq> prompt), but as soon as I 
try to run commands in it like associations or peers, it just comes back with 
that same error message.

I assume this has something to do with the first error message & that ntpq is 
trying (& failing) to bind to ipv6, but I'm unsure why that's the case.
Here's the output of ifconfig in case that helps:
        inet netmask 0xffffff00 broadcast
        inet6 fe80::204:61ff:fe46:be89%vr0 prefixlen 64 scopeid 0x1
        ether 00:04:61:46:be:89
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet netmask 0xff000000
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2

I've tried disabling my firewall and running ntpq -p again, but I still get 
the same response.
I've tried googling for a solution, but haven't found anything as yet so I 
hope someone here can help!

Here is my ntpd entries in rc.conf:
ntpd_enable="YES"               # Run ntpd Network Time Protocol (or NO).
ntpd_program="/usr/sbin/ntpd"   # path to ntpd, if you want a different one.
ntpd_flags="-c /etc/ntp.conf -p /var/run/ntpd.pid"

and the contents of ntp.conf:
server          augean.eleceng.adelaide.edu.au
driftfile       /var/db/ntpd.drift
logfile         /var/log/ntpd


GPG Key: http://homepages.picknowl.com.au/imoore/imoore.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20050111/54613be0/attachment.bin

More information about the freebsd-questions mailing list