NFS export of evolution

Erik Norgaard norgaard at
Mon Jan 10 13:04:12 PST 2005

Robert Marella wrote:
> On Mon, 2005-01-10 at 10:01 +0100, Erik Norgaard wrote:
>>Robert Marella wrote:
>>>I am not sure where this problem should go so I am posting to
>>>I have a SOHO set up with several computers running a mix of FreeBSD 5.3
>>>Release and Stable. I have an NFS server set up so that data can be
>>>shared at all of the computers.
>>>I would like to have the ability to retrieve mail from any of the
>>>computers I happen to be logged into. I have tried various permutations
>>>of exporting /home, /home/reg-user, and /home/reg-user/.evolution and I
>>>always get the same error when trying to read mail.
>>>I am able to mount the directory(ies) on the client computers and am
>>>able to call up evolution and see the messages but when I try to read
>>>any message I get this error
>>>Error while Retrieving message 1292 (this number varies of course)
>>>Failed to get lock using fcntl(2): Operation not supported.
>>>I read the man page for fcntl but I didn't get any help out of it. It
>>>was way over my head.
>>>Here is the important bits from /etc/exports
>>>/home/reg-user/.evolution -alldirs
>>>I have also tried -maproot with out any luck. I would think this is
>>>possible but I guess I haven't set up the right conditions or options.
>>>Can anyone help me out?
>>The error appears to be with filelocking not mounting. Filelocking is a
>>problem on NFS as many independent systems might try to get write access
>>to the same file at the same time. Do you have:
>>rpc_lockd_enable="YES" # Run NFS rpc.lockd needed for client/server.
>>rpc_statd_enable="YES" # Run NFS rpc.statd needed for client/server.
>>in your rc.conf?
> Eric,
> No I do not have that in my rc.conf. I tried adding it and got the same
> results. Should I try to change the values to ="NO" ??

No, default is "NO" (see /etc/defaults/rc.conf for further options). I 
don't know if you have to enable it on both client and server, and you 
also need rpcbind if it was not enabled.

Note, these are rpc-services, so if you have a strict firewall (that is 
any) your clients may not be able to access the lockd. Unfortunately 
there is no way of predicting which port lockd will bind to.

Btw I assume that after adding the above lines to your rc.conf you 
succesfully started the services :-) (both statd and lockd are started 
by /etc/rc.d/nfslocking start) you should be able to see to which ports 
they bind using 'sockstat -4':

daemon   rpc.lockd  3329  3  udp4   *:648                 *:*
root     rpc.lockd  3328  3  udp4   *:648                 *:*
root     rpc.statd  3323  5  udp4   *:805                 *:*

if you don't see it check in /var/log/messages if it registred properly 
with rpcbind. I just tried and found that lockd wouldn't start without 

I should add that I haven't really used statd/lockd, but from what I 
know, it appears your solution is somewhere in that direction. I hope 
this at least works as a pointer for you... :-)

Cheers, Erik

Ph: +34.666334818                                  web:
S/MIME Certificate:
Subject ID:  A9:76:7A:ED:06:95:2B:8D:48:97:CE:F2:3F:42:C8:F2:22:DE:4C:B9
Fingerprint: 4A:E8:63:38:46:F6:9A:5D:B4:DC:29:41:3F:62:D3:0A:73:25:67:C2

More information about the freebsd-questions mailing list