fxp driver on freebsd 4.7?

Kris Kennaway kris at obsecurity.org
Sun Jan 2 20:51:44 GMT 2005

On Sat, Jan 01, 2005 at 10:47:43PM +0800, Vincent Chen wrote:
> Hi, all
> I tried to install a new intel 82550 based ethernet adapter on my freebsd 4.7.
> In the first time, I don't want to recompile my kernel. So, I add the following
> line to /boot/loader.conf:
> if_fxp_load="YES"
> The driver loaded and the adapter identified as fxp0. But the system reboot
> every time while I tried to run ifconfig on fxp0. Did I do anything wrong using
> loadable module?

Perhaps, if it wasn't compiled at the same time as the kernel, it
might be incompatible and this will cause this kind of probblem.

> Or loadable module support not stable on this release.

4.7 is very old, so I doubt anyone remembers specific problems in this

> The second time, I compile fxp driver to my new kernel and every thing seem
> work ok. This 82550 adapter has 3des support bulletin, how can I identify this
> function enabled?

I doubt this is supported in 4.7.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20050102/49b2bd65/attachment.bin

More information about the freebsd-questions mailing list