4.10, USB problems

Gregor Mosheh stigmata_blackangel at yahoo.com
Sun Jan 2 10:21:51 PST 2005

For several months I've been using an external USB
hard drive, under 4.10 and the EHCI driver. It's
worked perfectly for months.

As of a month ago, when I swapped the drive for
another one, the drive has not worked properly. A few
days ago, my employer went on-site (the server is
colocated) to swap the drive. The new drive had the
same problem, and rebooting the server did not correct
the problem.

It was also reported that the last time he unplugged
the drive (the fs on the drive was not mounted) the
system crashed; he has since not plugged in the drive.

Now the details...

dmesg shows that it found a mass storage device and
properly identifies it, and usbdevs also reports the
drive; however, attempting to mount the drive causes
"mount: /dev/da0s1e: Device not configured" and the
message "umass0: BBB reset failed, TIMEOUT" appears in
the dmesg.

The external drive uses device usb4, since usb0
through usb3 are reported as USB1.

It was suggested that having both the USB1 (uhci) and
USB2 (ehci) driver may be causing confusion in the
kernel. I find this unlikely, though, since it's been
working for months.

Any thoughts or troubleshooting tips?

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the freebsd-questions mailing list