USB Mouse issues

Louis LeBlanc FreeBSD at
Mon Feb 28 21:35:52 GMT 2005

On 02/28/05 11:02 PM, Colin Alston sat at the `puter and typed:
> Louis LeBlanc wrote:
> >What really confused me was that I did not have moused enabled.  It
> >took quite a while to even realize that it was running.
> >
> >  
> >
> Hmmm, possibly then when I disabled moused in rc.conf it fixed it? I was 
> in too much of a tiss trying random things all at once.

Don't think you're the first one to do that :)

The fact I had never even enabled moused is exactly the reason I had
such a hard time finding it.  It just never occurred to me that usbd
was starting moused up behind my back.  Eventually, I realized this
was happening, killed moused and it worked.  Problem is the next time
I plugged back in, usbd would start moused again.  I had to comment
the mouse section out of /etc/usbd.conf and restart usbd
(/etc/rc.d/usbd restart) to get it to leave the pointers alone.

What I kept forgetting is that usbd would be restarting moused.  You
have to reconfigure usbd and restart it.  Then make sure moused isn't
running.  Then your mouse should be there at /def/ums0.  Your
xorg.conf mouse section will have to be configured to that device.

Louis LeBlanc                          FreeBSD-at-keyslapper-DOT-net
Fully Funded Hobbyist,                   KeySlapper Extrordinaire :)
Please send off-list email to:         leblanc at keyslapper d.t net
Key fingerprint = C5E7 4762 F071 CE3B ED51  4FB8 AF85 A2FE 80C8 D9A2

Gray's Law of Programming:
  `n+1' trivial tasks are expected to be accomplished in the same
  time as `n' tasks.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list