Why can't I access my floppy disk?

Loren M. Lang lorenl at alzatex.com
Fri Feb 25 13:36:08 GMT 2005

On Wed, Feb 23, 2005 at 05:11:37PM +0100, Anthony Atkielski wrote:
> Loren M. Lang writes:
> > Do you mean install a 1440k floppy image onto a disk or just copy a file
> > smaller than 1440k onto the msdos fs of an already formatted floppy.
> Specifically, I was trying to generate an installation boot floppy for
> FreeBSD, in order to install it on my other machine (which is too old to
> boot from CD).

If you were using one of the pre-fabbed floppy images provided by
freebsd like kern.flp then you would want to write it raw to disk, not
mount it, and this is forbidden at securelevel 3.

> > The latter should be ok even at securelevel 3, but the former can't
> > because that would mean open /dev/fd0 for writing other than a mount.
> I got the error just trying to mount the diskette.  I tried all
> different formats of the mount and mount_msdosfs commands and they all
> either generated a syntax error or told me that the operation was not
> permitted.

I don't know why this is, it should still be possible, especially since
you can mount cdroms.  /dev/fd0 is read/write by root right?  And the
disk already had a formatted filesystem on it before you tried mounting

> -- 
> Anthony
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

I sense much NT in you.
NT leads to Bluescreen.
Bluescreen leads to downtime.
Downtime leads to suffering.
NT is the path to the darkside.
Powerful Unix is.

Public Key: ftp://ftp.tallye.com/pub/lorenl_pubkey.asc
Fingerprint: B3B9 D669 69C9 09EC 1BCD  835A FAF3 7A46 E4A3 280C

More information about the freebsd-questions mailing list