Belkin PS/2 to USB converter, Not Pointing

Jed Clear clear at
Thu Feb 24 04:06:22 GMT 2005

In preparation for adding new box[1] to my stable[2] that uses USB for 
keyboard and mouse, I got a Belkin F5U119-E PS/2 to USB adapter for my PS/2 
keyboard and old Trackman Marble FX.  Since there will be a new USB KVM, I 
decided to try the adapter out with my FreeBSD 4.11-R server.  I managed to 
get the keyboard to work through the adapter, but not the Trackman.  I tried a 
grungy old Intellimouse in the adapter too, but no joy.  A real USB mouse, off 
my laptop, works just fine.

When I attach the adapter cable, I get this on the console/dmesg
    ukbd0: vendor 0x0d3d USBPS2, rev 1.10/0.01, addr 2, iclass 3/1
    kbd0 at ukbd0
    ums0: vendor 0x0d3d USBPS2, rev 1.10/0.01, addr 2, iclass 3/1
    ums0: 5 buttons and Z dir.
Note that the Trackman is 4 button, and no Z, and it reported 5,Z for the 
Intellimouse, too.  It also reports this when attached with no mouse, so it 
looks like there is a mouse emulator in the adapter, a la many KVMs.  A new 
instance of moused starts on ums0, when the adapter is inserted.

Figuring FreeBSD 4.11 and an AMD K6-233, on an Abit AX5 mobo, might be a 
little long in the tooth, I booted FreeBSD 5.3 off a FreeSBI 1.1 CD on an 
Athlon 1GHz (Abit KT7).  Same things occurred. I'd get the dmesg entries, and 
a new moused process, but no input from the mouse or Trackman.

The Trackman works with the adapter on the KT7 when it boots Windows ME[3], 
although the Logitech drivers can't even tell it's a Logitech device.  Which 
is worse than the normal KVM[4], but at least functional.  The Intellimouse 
works on the adapter under Windows as well, confirming the adapter isn't dead 
on arrival.  My current KVM was out of the loop for this testing.

I'm not running a GENERIC kernel, but one I stripped out for my hardware.  I 
already added uhid, ukbd, and ums back in.  I haven't tried ubsa(4), yet.  It 
looks close to perfect, but not really.  (Note that ubsa isn't in LINT.)

I'm fairly attached to the Marble FX, so would like to get this to work.

1) Is it worth trying the ubsa device driver?
2) Any other devices I might need?
3) Should I remove psm?
4) Something in another *BSD?
5) Are there other PS/2 to USB adapters known to work?
6) Know any good USB Trackballs?
7) Anything else I didn't think of?
8) Send a pr?

Thanks for any assistance,


[1] Hint: it's small, white[5], and runs a close cousin to FreeBSD, but with 
better eye candy.
[2] As in horses, not -STABLE.
[3] I'd get rid of it, except I need Quicken.
[4] Logitech drivers think it is a three button wheel mouse when looking 
through the KVM, which is about par for KVMs and trackballs.
[5] Think of 6 Beatles White Album CD Jewel boxes stacked with the corners 
rounded off.

More information about the freebsd-questions mailing list