Tape Drive -- broken?

Brandon Kuczenski brandon at 301south.net
Sun Feb 20 22:33:37 GMT 2005

I recently acquired an old IDE QIC/Travan tape drive (for free) and I'm 
trying to get it to work on FreeBSD 4.10-RELEASE.  I don't know for sure 
whether the unit is any good, but I would like to rule out operator error 
before I throw it away.

Here's what happens: at boot time, the tape drive is detected as device 

/kernel: ast0: TAPE <Seagate STT20000A> at ata1-slave PIO4

When I insert a brand-new 4/8GB tape and run 'mt -f /dev/ast0 status' as 
root I get the following output:

Mode      Density              Blocksize      bpi      Compression
Current:  0x01:X3.22-1983      512 bytes      800      none
---------available modes---------
0:        default              variable       0        none
1:        default              variable       0        none
2:        default              variable       0        none
3:        default              variable       0        none
File Number: 0  Record Number: 0        Residual Count 0

but I get the following message in /var/log/messages:

/kernel: ast0: TEST_UNIT_READY - HARDWARE ERROR asc=0xf0 ascq=0x36 

Similarly, if I run 'mt -f /dev/ast0 rewind', I get no output to the 
terminal but the following in the logs:

/kernel: ast0: TEST_UNIT_READY - HARDWARE ERROR asc=0xf0 ascq=0x36 
/kernel: ast0: REZERO - HARDWARE ERROR asc=0xf0 ascq=0x36 error=0x00

After either of these commands, if I run 'mt -f /dev/ast0 errstat' the 
terminal displays:

mt: /dev/ast0: Inappropriate ioctl for device

So, does this suggest the drive is fried, or am I doing something wrong? 
Google search shows that 'inappropriate' message popping up occasionally 
for all manner of devices on both Linux and BSD, but usually the hits are 
in the form of mailing list posts with few, if any, responses, and nothing 
that seems relevant to my situation.  Any ideas?

Thanks in advance,


More information about the freebsd-questions mailing list