probably a simple problem with permissions

Loren M. Lang lorenl at
Sun Feb 20 14:31:54 GMT 2005

On Mon, Feb 14, 2005 at 11:53:57PM -0500, David Wassman wrote:
> I am probably understanding this problem incorrectly meaning there is a 
> simple explanation that is escaping me. My /dev/cd0 is owned by root so  
> I have tried to change both the owner and the group so I can use it as a 
> user.
> I have tried:
> chmod 777 /dev/cd0
> chmod -R 777 /dev/cd0
> chgrp 777 /dev/cd0

It should at best be 666, and probably only 644 since cds are read-only.
I don't know if a cd burner needs to be 666 for ordinary users to burn
though.  device files, AFAIK, have no use for execute permissions.  And
I don't think 777 is a valid group name unless you decided to add it for
some reason.  If your cdrom device is cd0 then add "perm cd0 0644" to

> The problem is that when I reboot the system the old permissions return 
> and I have to su and change the permissions back. How do I make these 
> changes permanent? There is probably a security reason for  this but it 
> is very inconvenient on a desktop station. Any help would be 
> appreciated. I am running 5.3.
> David
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

I sense much NT in you.
NT leads to Bluescreen.
Bluescreen leads to downtime.
Downtime leads to suffering.
NT is the path to the darkside.
Powerful Unix is.

Public Key:
Fingerprint: B3B9 D669 69C9 09EC 1BCD  835A FAF3 7A46 E4A3 280C

More information about the freebsd-questions mailing list