Ramiro Aceves ea1abz at wanadoo.es
Wed Feb 16 12:45:01 GMT 2005

Hello FreeBSD friends.

I have read that others had this problem before. I just write this 
report for you to know.

I received yesterday two old computers retired from a school and finally 
I was able to build a  "decent" machine mixing the best parts of each 
one. The machine is an AMD K6 400 MHz with 64 MB RAM, AGP i740 video. 
Hard disk is Seagate ST34321A/3.05 master on ide0 bus. On ide1 bus there 
is a CD-R as master, and a CD-RW as slave. Disk controller is VIA 
82C586B UDMA33.

When I installed FreeBSD 5.3 R, I get some errors like this, but I could 
end the install:

ad0: WARNING -READ_DMA UDMA ICRC error (retrying request) LBA=5313599
spec_getpages:(ad0s1a) I/O read failure: (error=5) ................

I have solved the problem disabling DMA:

(I previously tried disabling ACPI with no success, and playing with 
BIOS LBA, LARGE, NORMAL settings at the BIOS with no success).

Now ad0: works in PIO4 mode and everything is fine, previously , it was 
UDMA33. Now there are no errors.

Should I investigate it further, or this is the only possible solution?
Should I expect a great performance decreasing in I/O disk access?

Thanks in advance.


More information about the freebsd-questions mailing list