problem with GCC search path on FreeBSD5.3 AMD64

Maicon Stihler mrkung at
Mon Feb 14 18:17:46 GMT 2005


I installed FreeBSD 5.3 for AMD64 on my computer following the
standard procedure. To my surprise, when I tried to compile new
packages I find out that /usr/local/lib and /usr/local/include wasnt
on gcc's search path. As a workaround I compiled the packages with
CFLAGS="-B /usr/local/lib -I/usr/local/include".

As far as I know, and the gcc info pages seems to agree, these too
directories should be in the default search path.

Is someone  else experiencing this same problem?
Is there a way to add these directories to the default path without
resorting to these env variables or runtime switches?

Note that I didnt changed anything from the default install, I even
tried installing again to see if something went wrong. I searched the
system for some config file but it turned to nothing...

Thank your in advance and sorry for my bad english :)

More information about the freebsd-questions mailing list