Messed up my ports - "Can't find the `5.1-RELEASE' distribution on this FTP server."

Joachim Dagerot jd at
Thu Feb 10 14:17:14 PST 2005

On 2005-02-10 Kent Stewart  wrote:

On Thursday 10 February 2005 07:14 am, Joachim Dagerot wrote:
>> I have probably done something sometime on my 2 year+ server
>> installation that wrecked my port installation.
>> Whenever I try to install a port I get the "Can't find the
>> `5.1-RELEASE' distribution on this FTP server." the same goes with
>> "sysinstall -> configure -> Distributions" I have tried multiple
>> servers including the main. With the same result.
>> I really don't know what to do. Any help is appreciated!
>Ports don't go by releases like you are trying to do. If you look at
>You will see that nothing before 5.2 is there now. The current set of 
>packages, which is what you are loading, would be located in 
>Are you really still using 5.1? That was not considered a production 
>release. The current version is 5.3 and was the first to be given the 
>name of 5-stable.

Thanks for your answer. I managed to install the ports distribution by the help of another mail. But yes I think I am using the 5.1 release. Don't ask me how or why. I have been running cvsup for all the ports now and then for a couple of years and everytime there's a lot of changes coming in.

I am just a unix guy that likes my shell. I don't know and don't have too much interest in following the development paths and all the various tags.  When I installed my 5.1 everyone said I should go for 4x but I didn't and it has never failed me.

Now when you're pointing out that I run such an old version I googled a bit to find how to upgrade but to be honest, I still really don't get it, but I'll post a new mail about that.

More information about the freebsd-questions mailing list