jail manpage

Chad Leigh -- Shire.Net LLC chad at shire.net
Thu Feb 10 00:51:21 PST 2005

On Feb 10, 2005, at 12:50 AM, r p wrote:

>> On Wed, 9 Feb 2005 14:12:06 -0600, Josh Paetzel <josh at tcbug.org>
> wrote:
>>> I've been trying get jails working on my 5.3-RELEASE-p2 machine.
>>> I've tried following the instructions in man 8 jail
>>> D=/here/is/the/jail
>>> cd /usr/src
>>> mkdir -p $D
>>> make world DESTDIR=$D
>>> cd etc
>>> make distribution DESTDIR=$D
>>> mount_devfs devfs $D/dev
>>> cd $D
>>> ln -sf dev/null kernel
>>> It dies at make world DESTDIR=$D with the following error:
>>> cc -0 -pipe -I/usr/obj/usr/src/i386/legacy/usr/include
>>> c/usr/src/games/fortune/strfile/strfile.c
>>> make: don't know how to make /jail/test/usr/lib/libc.a. Stop
>>> ***Error code 2
>>> Stopping /usr/src
> Hi,
> I had the same problem. Googling showd me to use the line "env
> DESTDIR=$D make world" instead of "make world DESTDIR=$D". After I did
> this it all worked fine.

Hmm, I will have to try that.  I posted this same problem a few days 
ago.  Never did get an answer, though I figured out a solution myself.  
This problem actually goes back to when 5.3 first came out.  There was 
a problem and the fix got committed to the -STABLE branch but it 
appears it never got into the -RELEASE branch.  I went to 
5.3-RELEASE-p5 about  a week ago and had a similar or same problem as 
the OP.

My solution was to take the Makefile and Makefile.inc from the root of 
the source directory from a -STABLE src tree and stick them in my 
-RELEASE source tree.  That allowed me to build fine and the jails work 
just fine.  Of course, this is not the best solution.


More information about the freebsd-questions mailing list