determine ufs2 %fragmentation on mounted filesystem

Nikos Vassiliadis nvass at
Wed Feb 9 10:06:22 PST 2005

On Wednesday 09 February 2005 19:30, Nathan Kinkade wrote:
> I had already tried dumpfs, but couldn't find any information about
> actual filesystem fragmentation in the output.  Erik's suggestion of
> running `# fsck -t ufs2 /usr` seemed to work, though I felt a little
> skittish about running it on a live filesystem.  
You can(must) use mksnap_ffs to take a snapshot and fsck that. Note that
snapshots are meant to be read-only, so fsck -n, mount -r etc...

> It found numerous 
> errors and auto-answered "no" for all of them, though I never specified
> that it should do that.  Does fsck just do this by default on a mounted
> filesystem?  Also, I had tried running fsck manually earlier and the
> only difference between what I did and Erik's suggestion was the -t
> option, which I wouldn't think should have been necessary.  Shouldn't
> fsck be able to determine the fs type by looking at the superblock?
> By the way, the fragmentation was as 5.1%.  Quite high, and I'm
> wondering how it got that way?  Squid?
> Thanks,
> Nathan

More information about the freebsd-questions mailing list