repost of boot issue on 5.3

Chris Hodgins chodgins at
Sat Feb 5 15:31:11 PST 2005

J.D. Bronson wrote:
> At 05:19 PM 2/5/2005, Chris Hodgins wrote:
>> J.D. Bronson wrote:
>>> No one responded - I am sure someone out there knows what the deal is 
>>> here...
>>> I did a full install from CDROM on a fresh new clean drive.
>>> Freebsd is the ONLY OS on the drive. And i used the entire drive.
>>> I selected the standard boot manager (not the freebsd one)...
>>> and all the install went fine. This is what I see when I reboot after 
>>> install:
>>> FreeBSD/i386 BOOT
>>> Default: 0:ad(0,a)/boot/loader
>>> boot:
>>> ..and it JUST SITS there. If I hit the return key, it will boot up 
>>> into the beastie menu and boot fine. How can I get this machine to 
>>> boot up on its OWN?
>>> The boot startup sequence on the machine is HARD DRIVE THEN CDROM.
>>> This is the only hard drive in the system.
>>> Please if anyone knows how to fix this?? - A fresh install with a 
>>> fresh drive....and still no luck.
>> This might give you a few ideas. :)
>> Chris
> I tried this (even tho a full install it SHOULD not be needed) and I 
> still get the same darn thing. I am really disappointed as I dont know 
> why its hanging.

My /boot/loader.rc file looks like this:

/boot$ cat loader.rc
\ Loader.rc
\ $FreeBSD: src/sys/boot/i386/loader/loader.rc,v 1.2 2003/11/21 19:01:02 
dcs Exp $
\ Includes additional commands
include /boot/loader.4th

\ Reads and processes loader.rc

\ Tests for password -- executes autoboot first if a password was defined

\ Load in the boot menu
include /boot/beastie.4th

\ Start the boot menu

This seems to be the place where you get it to load the right 
things...check that out.  I am no expert btw. :)


More information about the freebsd-questions mailing list