How to get /etc/ssh back

Sean P. Malone smalone at
Wed Aug 31 16:16:59 GMT 2005


I installed openssh-portable and that worked.

I did have to create symlinks from /etc/ssh to /usr/local/etc/ssh and 
/usr/sbin/sshd to /usr/local/sbin/sshd. In my case, the sshd_program 
line in /etc/rc.conf didn't force the system to use the portable sshd as 
opposed to the base.  Thus, I commented out the line and just used a 

Thanks, again!


albi at wrote:
> On Tue, 30 Aug 2005 16:04:32 -0500
> "Sean P. Malone" <smalone at> wrote:
>>I "mistakenly" deleted /etc/ssh along with all of the keyfiles and, most 
>>importantly, ssd_config.  I was attempting to completely 
>>remove/reinstall openssh.
>>I've tried both the port and package.  The install program doesn't 
>>complain that there is no /etc/ssh.  I had assumed that it would create 
>>it but it evidently does not.
>>The system does ask for entropy upon the next reboot but the generation 
>>of the keys and startup of sshd fail since there is no /etc/ssh.
>>If the install program doesn't create /etc/ssh, what does and how do I 
>>get it back?
> first of all, /etc/ssh is the config-home of the "base" ssh that comes
> with FreeBSD by default (so you can use "make world" to get it back")
> however the openssh-portable port is storing these config-files
> in /usr/local/etc/ssh, if you want to switch to the port instead of the
> base-system ssh, then do the following :
> sshd_enable="YES"
> sshd_program="/usr/local/sbin/sshd"
> (see also : /usr/share/examples/etc/defaults/rc.conf)
> after this is working well, imo it's a good idea to
> remove /usr/sbin/sshd and /usr/bin/ssh* and /etc/ssh (or
> replace them with symlinks to the port-binaries etc.)

More information about the freebsd-questions mailing list