Directory permissions issue taring directories onto a Compact Flashcard

Paul Hamilton paulh at
Sun Aug 28 13:10:40 GMT 2005

Well, I never really resolved this.  I later tried taring at a sh prompt.
Same deal.  I had tried manually chmoding the /mnt dir. To 777, but that
didn't help either.

In the end I gave up, and did a fresh install straight onto the CF drive
from the CD.  I did try a 6.0 beta3 install, but it kept crashing early in
the install process, so 5.4 it is (for the time being).



> -----Original Message-----
> From: owner-freebsd-questions at 
> [mailto:owner-freebsd-questions at] On Behalf Of 
> Paul Hamilton
> Sent: Saturday, 27 August 2005 10:28 PM
> To: freebsd-questions at
> Subject: Directory permissions issue taring directories onto 
> a Compact Flashcard
> Hi,
> I have done a minimal FreeBSD 5.4 install onto single 
> partition ad0s1a  I then mounted my 512MB Compact Flash ide 
> drive on ad2s1.
> When I run this command su'ed as root: 
>    tar --one-file-system cf - -C / . | tar xpvf - -C /mnt
> I find that all the directories end up with permissions of:   
> drwx------
> Even running:   dump 0af - / | restore xf -   gives the same result.
> If I manually create a directory on the CF /mnt I get the 
> correct permissions!  Files copied over via tar and dump are 
> ok.  I have used tar to copy HD contents to larger HD,s 
> before with out a problem.
> Umask is set to 22, and this is being done in a tcsh shell. 
> Any clue on whats going on?
> Cheers,
> Paul Hamilton.
> _______________________________________________
> freebsd-questions at mailing list 
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list