/rescue/vi doesn't work without /usr (no terminal db)

N.J. Thomas njt at ayvali.org
Thu Aug 25 18:45:38 GMT 2005

* Alex Zbyslaw <xfb52 at dial.pipex.com> [2005-08-25 19:22:48 +0100]:
> >   BUGS
> >
> >       Most of the rescue tools work even in a fairly crippled system.
> >       The most egregious exception is the rescue version of vi(1),
> >       which currently requires that /usr be mounted so that it can
> >       access the termcap(5) files.
> Will ex not work?  Since it's just vi without graphics it shouldn't need 
> a termcap (which doesn't mean it won't want one of course).  What was 
> $TERM set to?

/rescue/ex did not work, it gave the same error that /rescue/vi did,
namely that the termcap/terinfo database was not found.

$TERM was set to cons25

> Having said that, I can still remember a time when any sysadmin worth
> tuppence would know how to use ed because that was all that worked on
> a teletype :-)

Yes, /rescue/ed did work, and of course I am glad that something was
working, but ed is infinitely more tedious to work with than vi.

But when things have gone so wrong that you actually have to use the
tools in /rescue, you are generally not in the mood to deal with
something as archaic as ed. =-)


N.J. Thomas
njt at ayvali.org
Etiamsi occiderit me, in ipso sperabo

More information about the freebsd-questions mailing list