Can only boot in safe mode - FreeBSD 5.4

illy . illy.inspace at
Wed Aug 17 17:38:36 GMT 2005

Hi, I was wondering if anyone could help me. I'm having major dramas
getting FreeBSD working on my Laptop.
It is a Compaq Presario M2000.
System specs:
CPU - Mobile AMD Sempron(tm) Processor - 1600 MHz
Motherboard - Quanta 3091
RAM - 256 MB DDR
Disk Drive - ST94019A (37 GB, IDE)
Optical Drive - HL-DT-ST RW/DVD GCC-4244N
Video Adapter - ATI RADEON XPRESS 200M (32 MB)
Audio Adapter - Conexant AC-Link Audio

I will tell you step by step what I've been through.
1. I could only boot in safe mode in 5.4 - yet when I finished the
install it didn't write the boot manager to the mbr. So I tried using
a couple of other boot managers (gag, grub) but non of those would
install either.
2. I decided to install a minimal 4.11 install. 4.11 would only
boot/install disabling sio0. But it worked and installed the FreeBSD
Boot manager, which is all I wanted.
3. Then I once again installed 5.4 in safe mode. It worked fine then
as the boot manager that 4.11 had put there was still there.

Yet I can still only boot in safe mode.
Now I know that safe mode disables ACPI, the APIC, ATA and ATAPI DMA,
ATA write caching, and all EISA devices. So I figure that it is
something here that is my problem.

When I boot in to default it gets to 
ioacpi0 <Version2.1> irqs 0-23 on motherboard
then freezes, and goes to a blank screen, and the only way out is the
power switch.

When I boot with ACPI disabled - it gets to the same thing, then it
does the same thing.

When I add 'debug.acpi.quirks=4' into the /boot/loader.conf file. The
default boot gets to:
Timecounters tick every 10.000 msec
Then freezes

The Verbose boot gets to:
Timecounters tick every 10.000 msec
lo0: bpf attached
Then freezes.

And the ACPI disabled boot gets to:
cpu0 on motherboard
Then freezes.

I have tried adding a couple of other options to the /boot/loader.conf
file. Now of which make any difference at all, including:
hw.ata.atapi_dma="0" and "1"
and even telling it that it is Windoze.
There are a couple of other options I have added to, but I cant think
of them now my head is swimming :s.

Some of the outputs are - 
# vmstat -i
interrupt                          total       rate
irq0: clk                          65946         99
irq1: atkbd0                         429          0
irq4: fwohci0                       4584          6
irq5: rl0                             26          0
irq7:                                  1          0
stray irq7                             1          0
irq8: rtc                          84410        127
irq11: ohci0 ohci1                   272          0
irq12: psm0                          124          0
irq13: npx0                            1          0
irq14: ata0                         1752          2
irq15: ata1                           46          0
Total                             157592        238

The dmesg for the safe mode boot is:
# dmesg
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 5.4-RELEASE #0: Sun May  8 10:21:06 UTC 2005
    root at
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Mobile AMD Sempron(tm) Processor 2800+ (1600.07-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x10fc0  Stepping = 0
  AMD Features=0xc0500000<NX,AMIE,DSP,3DNow!>
real memory  = 233766912 (222 MB)
avail memory = 219099136 (208 MB)
npx0: <math processor> on motherboard
npx0: INT 16 interface
cpu0 on motherboard
pcib0: <Host to PCI bridge> pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 5.0 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xd0000000-0xd0000fff irq
11 at device 19.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: (0x1002) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xd0001000-0xd0001fff irq
11 at device 19.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: (0x1002) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 4 ports with 4 removable, self powered
pci0: <serial bus, USB> at device 19.2 (no driver attached)
pci0: <serial bus, SMBus> at device 20.0 (no driver attached)
atapci0: <GENERIC ATA controller> port
0x8410-0x841f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 20.1 on
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
isab0: <PCI-ISA bridge> at device 20.3 on pci0
isa0: <ISA bus> on isab0
pcib2: <PCI-PCI bridge> at device 20.4 on pci0
pci5: <PCI bus> on pcib2
rl0: <RealTek 8139 10/100BaseTX> port 0xa000-0xa0ff mem
0xd0208000-0xd02080ff irq 5 at device 0.0 on pci5
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:c0:9f:b0:1a:af
pci5: <network> at device 2.0 (no driver attached)
cbb0: <PCI-CardBus Bridge> mem 0xd0209000-0xd0209fff irq 10 at device
9.0 on pci5
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
fwohci0: <1394 Open Host Controller Interface> mem
0xd0200000-0xd0203fff,0xd0208800-0xd0208fff irq 4 at device 9.2 on
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:c0:9f:00:00:5e:ae:e5
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:c0:9f:5e:ae:e5
fwe0: Ethernet address: 02:c0:9f:5e:ae:e5
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc000ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
pci5: <mass storage> at device 9.3 (no driver attached)
pci5: <base peripheral> at device 9.4 (no driver attached)
pci0: <multimedia, audio> at device 20.5 (no driver attached)
pci0: <simple comms, generic modem> at device 20.6 (no driver attached)
orm0: <ISA Option ROMs> at iomem
0xe0000-0xe3fff,0xdc000-0xdffff,0xd0000-0xd0fff,0xc0000-0xcffff on
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x64,0x60 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources (port)
unknown: <PNP0c02> can't assign resources (memory)
unknown: <PNP0c02> can't assign resources (memory)
unknown: <PNP0f13> can't assign resources (irq)
Timecounter "TSC" frequency 1600071465 Hz quality 800
Timecounters tick every 10.000 msec
Interrupt storm detected on "irq4: fwohci0"; throttling interrupt source
ad0: 38154MB <ST94019A/5.11> [77520/16/63] at ata0-master PIO4
acd0: CDRW <HL-DT-STCD-RW/DVD DRIVE GCC-4244N/1.01> at ata1-master PIO4
Mounting root from ufs:/dev/ad0s2a

I am desperate, and I don't know what to try next. I have searched
google, man pages, articles, and anything I can get my hands on, but
to no avail. I was going to add apm to the kernel and try that yet,
the warning in the man pages scares me:
"WARNING!  Many, if not most, of the implementations of APM-bios in
lap-tops today are buggy.  You may be putting your LCD-display and
batteries at a risk by using this interface."
I cant afford, this it took me nearly a year to save up for this
lap-top, and I just cant lose it (I cant eat I'm so poor from buying
By the way I'm only a newbie (2 months in FreeBSD), yet I'm willing to
do what ever it takes. If I haven't placed enough detail here let me
know. Anything else I can provide I will. I just really need to get
this working.
Please Please if anyone could help I would be so incredibly grateful!
Thankyou illy

More information about the freebsd-questions mailing list