After Partitioning a Drive: WARNING - WRITE_DMA UDMA ICRCerror (retrying request)

Mark Kane mark at
Tue Aug 16 23:26:01 GMT 2005

OK. Now I really am at a loss for words. I experienced my first FAILURE 
message this morning when trying to fdisk my last newly formatted 160GB 
drive. The second fdisk would start to write, my screen would fill with 
WRITE_DMA WARNINGS and FAILURES. That was with another drive on the same 
controller. I removed that drive, and everything works fine.

I just got another brand new 200GB drive within the last hour. Even it 
on the same channel as anything else causes errors upon mount, and 
FAILUREs as well. Then I cannot shut down properly because the errors 
continue even to the shutdown sequence. Then on the next boot I get 
messages about things not being properly dismounted. (First time 

I don't know if it's hardware or FreeBSD anymore. I read this thread on 
freebsd-stable earlier today, and then all of a sudden I start getting 
all the failures that I never got before:

So please, anybody...Is this a controller incompatibility with my other 
hardware (drives) or a FreeBSD problem?

Up until now I was 98% certain it was hardware in some way, but now I'm 
not sure. I have the opportunity to get an Asus board to test, but I'm 
not going to shell out money for something if it isn't even a hardware 

Thanks very much.


Mark Kane wrote:
> Well, it's a week later and I've been trying some things. I don't want 
> to get in to too much complicated detail, but I've now got the following 
> disk setup:
> Primary Master - 200GB 7200RPM
> Secondary Master - TDK VeloCD CD Burner
> Secondary Slave - Sony DRU500A
> RAID0 Master - 160GB 7200RPM
> RAID0 Slave - 160GB 7200RPM
> I don't have the two 80GB's or 60GB's in there now since I was just 
> testing with this setup. I thought keeping the OS drive on primary 
> master and the rest on RAID would do the trick, but it didn't.
> Bottom line is, I'm still getting the same errors with several different 
> configurations of the drives. Now in the last couple of days I'm also 
> getting READ DMA errors when reading from one of the 160GB drives as 
> well. Before it was all just WRITE, but now some READs are thrown in 
> there as well.
> I should note that I have never seen a "FAILURE" message, only the 
> "WARNING" messages. Also, if I downgrade the speed to UDMA100, it seems 
> to work just fine as it does in UDMA66 mode.
> I'm wondering if anyone else has any ideas? Personally I'm out, and if 
> nobody else knows (including Maxtor, Giga-Byte, and my parts 
> distributor) then I'm going to have to see what I can do to get another 
> brand/model motherboard. I'm to the point where I think it's something 
> with their controller and how it handles Maxtor drives. Now that I 
> remember, I used to see similar results when running Windows on the 
> previous board before sending it in (same model). However Windows would 
> automatically take it down to 100 so I didn't see any errors.
> Anyone think its something other than the board and it's controllers, or 
> is that a pretty good estimate?
> Thanks in advance.
> -Mark
> Mark Kane wrote:
>> Okay well I tried another test. I left the 160GB on the primary IDE 
>> channel, took out both optical drives, and put the 60GB on the 
>> secondary IDE channel by itself.
>> I copied the data over again. No errors this time. I checksummed the 
>> data, and everything is OK.
>> Chuck Swiger wrote:
>>> Without another known-working mainboard to test, you can't really be 
>>> sure, but it's a hardware problem of some sort, perhaps due to poor 
>>> cabling, perhaps a marginal or failing mainboard.
>> The cables are new, and the other drive on the same channel works in 
>> UDMA133 with no errors.
>> The motherboard is new as well, fresh from the factory (unless it's 
>> defective).
>>> If you use BIOS or atacontrol to slow down to UDMA 33 speeds, does 
>>> everything work OK?
>> I tried slowing it down to UDMA66 speeds via atacontrol, and the 
>> errors went away on the 80GB. I haven't tried the 60GB drive yet.
>> -Mark
>> _______________________________________________
>> freebsd-questions at mailing list
>> To unsubscribe, send any mail to 
>> "freebsd-questions-unsubscribe at"
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list