STB2 capture card; sound works in btwincap and bttv, but not in bktr

tweek tweek.20k at
Sat Aug 13 23:27:02 GMT 2005

I have a STB capture card, distributed in an OEM package by Gateway.
(I purchased it through eBay for $12.) It has a bt878 chip, and I have
it hooked to an SB Live! card with a four-pin audio cable, internally.
The card has both RCA and S-Video video inputs, a 'headphone'-style
jack for audio input, and two coaxial inputs - one for cable TV, the
other for an FM antenna.

I used it over the summer to play Halo 2 through, with Windows XP and
btwincap. I needed to change a few settings, (specifically, the
presence of and addresses of a few chips) as noted in, for sound to play: (what
follows is a quote from that page)

- TDA 9850 set to "Yes", 12c address 0xb6, (also try 0xb4 if audio
does not work)
- TEA 6420 set to "Yes", 12c address 0x98
- TDA 7432 set to "Yes", 12c address 0xff (the driver will autodetect it)

I usually have to set the TDA 9850 I2C address to 0xb4 to make sound
play. I use ATV2000 after that, and have no problems with S-Video
input, cable TV, etc. - everything works.

I tried Knoppix a while ago - using fxtv through its relatively easy
configuration script, (essentially, all it asks is, what card do you
have, what tuner does it have, etc.) I was able to make everything
work - with sound - without any changes.

I've been trying a number of things to get sound to play in FreeBSD.
Here is a list of things I've tried so far:

fxtv auto/internal switch: does nothing.
mixer all volumes to 100: necessary, of course, for this to work, but
does nothing.
xawtv: no change from fxtv. (these are the only two FreeBSD capture
card-specific applications I know of; mplayer was also tried, with no
new msp34xx patch: no change noted.
playing with various hw.bt848 (848...?) sysctl tunables: no change.
doing anything to the emu10k1 driver/using emu10kx: no change. (this
isn't the problem, I'm pretty sure.)
kernel sourcediving: found a few references to TDA 98something, and
messed around with a few things, but ... really no changes noted.

Here are some relevant-looking lines from dmesg:

bktr0: <BrookTree 878> mem 0xd0001000-0xd0001fff irq 5 at device 15.0 on pci0
bktr0: STB TV/PCI, Philips FR1236 NTSC FM tuner, dbx stereo.
pci0: <multimedia> at device 15.1 (no driver attached)

uname -a reports that I'm using FreeBSD 5.4-RELEASE-p6. Here are some
lines from my kernel config:

device          bktr
device          iicbus
device          iicbb
device          iicsmb
device          smbus
options         OVERRIDE_CARD=3
options         OVERRIDE_TUNER=9
#options      BKTR_NEW_MSP34XX_DRIVER
#options      BKTR_GPIO_ACCESS

A bit of Googling shows an old post someone who seems to have the same
the same problem, and also seems to know a bit more about it:

I'd appreciate any help I could get with this. I'll be moving into a
dorm room (hopefully) once the term starts, and it'll probably be
annoying to switch to Windows XP from FreeBSD just to watch a few NHL
games, and my computer is slow enough to make anything like VMware

Lucas Jacobs, FreeBSD user since 5.2
tweek (dot) 20k (at) gmail (dot) com

More information about the freebsd-questions mailing list