Mambo CMS on freeBSD5.4

Chris Ryan chris.ryan at
Fri Aug 12 16:08:23 GMT 2005

Hi All

I have tried to find documentation on how to setup a freeBSD box as a
webserver running PHP apach mySQL versions needed for the Mambo content
Management System [ the one that has won lots of open sourse awards over the
last few years] So I am sure there must be others wanting this resource -
and I will be happy to help with documentation [ and anything else I can do]
for others once my issues are resolved.

I have searched the handbook, archives for questions etc etc

Sorry for the long email - but thought I would give as much info as
possible, thanks in Advance.

I have an IBM p4 1.6 w 256mb RAM 40 gig.

I have installed freeBSD 5.4.

I cvsuped ports-all and src-all


cd /usr/ports/www/apache13-modssl
make install distclean

echo 'apache_enable="YES"' >> /etc/rc.conf
echo 'apache_flags="-DSSL"' >> /etc/rc.conf

  cd /usr/ports/databases/mysql40-server
make install WITH_OPENSSL=yes distclean

cd /usr/ports/www/mod_php4
make install distclean
cd /usr/ports/lang/php4-extensions
make install distclean

Checked the OpenSSL boxes when needed

ee  /usr/local/etc/apache/httpd.conf

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

openssl genrsa -des3 -out server.key 1024

openssl req -new -key server.key -out server.csr

  openssl x509 -req -days 365 -in /root/server.csr -signkey /root/server.key
-out /root/server.crt

cp ~/server.key /usr/local/etc/apache/ssl.key/
cp ~/server.crt /usr/local/etc/apache/ssl.crt/

 /usr/local/etc/rc.d/ start
/usr/local/sbin/apachectl startssl

***next three lines to stop needing pwd for ssl on each system reboot
***cd /usr/local/etc/apache/ssl.key
***cp server.key server.key.orig
***openssl rsa -in server.key.orig -out server.key

Then scp mambo files and

At this stage I can point browser to ip address and the proper Mambo
pre-installer page comes up - as it should.

With PHP Zlib Mysql all coming up positive. [ as needed by Mambo ]

Now I try to create a database in mysql called Mambo

mysqladmin -u root -p create Mambo

I enter my password then get this error message

mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/tmp/mysql.sock'
Check that mysqld is running and that the socket: '/tmp/mysql.sock' exists!

I have tried to start mysql again with  /usr/local/etc/rc.d/

I have restarted [ of course ]

I have noticed that the file /tmp/mysql.sock does not exist. I have tried to
get some info form mysql's site with no luck.

I love and promote freeBSD whenever I can! Its such a great system!

Thanks in Advance for help



More information about the freebsd-questions mailing list