Epson Stylus C86 and apsfilter

Kep Woof kep.woof at
Sun Aug 7 20:24:04 GMT 2005


i needed a printer so i checked and thought an epson
c86 would be a good idea.  i'm trying to set it up using usb.

now i've googled off and on for a few days now, and seen that people
have strong opinions as to whether they use CUPS or not.  i tried a
few printcap recipies that i wasn't sure how to use, and after more
reading saw that the recommended driver for my printer was gimp-print.
 ideally i'd like something simple, that i can later use with samba,
so i was thinking along the lines of lpr or lprng.

so more fiddling, and i've got apsfilter and ghostscript-gnu-nox11
installed, and choose the closest driver from the nice apsfilter menu
- epson stylus c80.  i fill in the other details, and it seems fine -
/dev/ulpt0 & a4 - but when i try the test page i get lines of text on
the paper as follows:


for pages and pages.  i've not let it finish, just turned off the
printer, to save ink.  there didn't seem much point in letting it go
on.  i've tried with other drivers from the same section, but with no

here's the last thing apsfilter says before it starts printing the <<?<<'s:

Printing Test page using:
gs -q -dBATCH -dNOPAUSE -dPARANOIDSAFER                 -dSAFER
-r360x360 -sDEVICE=ijs -sPAPERSIZE=a4           
-sDeviceManufacturer=EPSON -sDeviceModel='escp2-c80'            
-sIjsServer=ijsgimpprint -dIjsUseOutputFD 
-sOutputFile='/tmp/apsfilter1514/test_page.aps' setup/

from dmesg:

ulpt0: EPSON USB Printer, rev 1.10/1.00, addr 2, iclass 7/1
ulpt0: using bi-directional mode

i've tried running escputil.  it moves the print head and displays the

#escputil -i -u -r /dev/ulpt0

Escputil version 4.2.7, Copyright (C) 2000-2001 Robert Krawitz
Escputil comes with ABSOLUTELY NO WARRANTY; for details type 'escputil -l'
This is free software, and you are welcome to redistribute it
under certain conditions; type 'escputil -l' for details.

Read from printer timed out

Read from printer timed out
Cannot parse output from printer

when i ran it a second time it just repeated the second message:

Cannot parse output from printer

i've tried with both gnu and afpl ghostscript, for x11 and nox11 on 2
different machines.  the printer does work ok from windows, so i guess
that rules out cable problems.  i've read loads about printers this
weekend, and am completely confused.  does anyone have any ideas as to
how i can go about properly diagnosing and fixing this problem?

thanks in advance for any help or suggestions.


ps.  please cc on any replies as i'm not on the list.  thanks!

More information about the freebsd-questions mailing list