How to recover data? - Formatted, Fdisk'd, and disklabeled ad1, now ad0 with FreeBSD is messed up

Mark Kane mark at
Sun Aug 7 18:20:55 GMT 2005

Hi everyone. I am in the process of taking the data from 4 NTFS drives, 
copying them to a temporary drive, and then formatting them, and 
creating partitions in UFS to be used with FreeBSD. I was having some 
problems with DMA errors on one of the drives yesterday, so it was 
suggested I try another one of the drives to narrow down the problem.

So last night, I copy a nearly full 60GB drive (ad1) to my 160GB 
temporary FreeBSD drive (ad0). I checksum all the data to make sure it 
all copied correctly, and shut down for the night.

This morning, I came back to format the 60GB drive. I formatted it and 
ran it through fdisk and disklabel. Whenever I do something like this, I 
always make sure I double and triple check that it says the correct 
drive at the top. In this case, it did. It said at the top I was 
modifying ad1 (the 60GB).

I mounted the drive to make sure it worked, and it did. I went to reboot 
one final time, which I guess I shouldn't have done. After rebooting, it 
didn't come to the FreeBSD boot screens. I tried rebooting a few more 
times in case something happened along the way. Still nothing.

I found the FreeBSD 5.4 install CD and booted to the FixIt live 
filesystem. I tried to look for my ad0 data, and I only saw /dev/ad0 and 
/dev/ad0s1. I mounted /dev/ad0s1, and it's my root (/) partition from 
before. I don't see any ad0s2, ad0s3, ad0s4, etc.

As for ad1, I see ad1s1, ad1s1c, and ad1s1d. ad1s1 gives "Operation Not 
Permitted" when I try to mount it. ad1s1c and ad1s1d just show ".snap/" 
directories when I mount and ls them.

If anyone has any suggestions I would be very much obliged. The 160GB 
drive (ad0) has two nearly full hard drives' data, and almost 10 years 
of important data on it.

Thanks very much in advance.


More information about the freebsd-questions mailing list